Recent

Author Topic: v2.0 Not Starting  (Read 257 times)

HatForCat

  • Sr. Member
  • ****
  • Posts: 273
v2.0 Not Starting
« on: April 25, 2019, 09:58:34 pm »
Hi All,

Had to go back to an early image backup of Mint so un-installed 1.8.4 with Synaptic. Rebooted just for fun then installed v2.0 in the correct sequence with gdebi.

On the first run I never got that dialog with the "Folders, All OK." I just got the splash screen with v2.0 on the bottom. A few seconds later it disappeared and that's it. Nothing.

I did some searching and cannot find anything for what to do next. Part of that searching issue is what terms to search for. :)

"not running"
"not starting"

Neither seem to be helpful. I desperately need Lazarus to make a change to my email program.

p.s. I also tried the "sudo apt install -f ....deb" process I found mentioned here but same again, Splash and dash.

« Last Edit: April 25, 2019, 10:02:21 pm by HatForCat »
Acer-i5, 2.6GHz, 6GB, 500-SSD, Mint-19.1, Cinnamon Desktop, Lazarus 1.8.4, SQLite3 -- Retired after 40+years programming, still cannot stop.

john horst

  • New member
  • *
  • Posts: 43
Re: v2.0 Not Starting
« Reply #1 on: April 26, 2019, 12:19:37 am »
run "lazarus-ide" in the terminal. The output might give you more insight to why it's crashing.

HatForCat

  • Sr. Member
  • ****
  • Posts: 273
Re: v2.0 Not Starting
« Reply #2 on: April 26, 2019, 01:19:54 am »
run "lazarus-ide" in the terminal. The output might give you more insight to why it's crashing.

Thanks, I decided to check for an update and found 2.0.2 so downloaded and installed the .deb. It found the other install so I opted to use the new one and it now launches OK. Seems some tweaking of the Linux install has been added in 2.0.2.

I had tired launching in the IDE but didn't use the correct name. I had tried with "lazarus" missing the "-ide" and got the "couldn't find" message. All good now though, but thanks anyway.
Acer-i5, 2.6GHz, 6GB, 500-SSD, Mint-19.1, Cinnamon Desktop, Lazarus 1.8.4, SQLite3 -- Retired after 40+years programming, still cannot stop.

lucamar

  • Hero Member
  • *****
  • Posts: 1483
Re: v2.0 Not Starting
« Reply #3 on: April 26, 2019, 01:35:20 am »
I had tired launching in the IDE but didn't use the correct name. I had tried with "lazarus" missing the "-ide" and got the "couldn't find" message.

Next time, try with: startlazarus

That's the "canonical" way of starting lazarus :)
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus 1.8.4 & 2.0.2 w/FPC 3.0.4 on:
(K|L)Ubuntu 12..16, Windows XP SP3, various DOSes.

HatForCat

  • Sr. Member
  • ****
  • Posts: 273
Re: v2.0 Not Starting
« Reply #4 on: April 26, 2019, 03:23:48 pm »

Next time, try with: startlazarus

Ha, that worked. I never would have though of trying something like that.

Thanks anyway.
Acer-i5, 2.6GHz, 6GB, 500-SSD, Mint-19.1, Cinnamon Desktop, Lazarus 1.8.4, SQLite3 -- Retired after 40+years programming, still cannot stop.