Recent

Author Topic: Problem with libsqlite3.dylib on OSX  (Read 693 times)

ahnz

  • Jr. Member
  • **
  • Posts: 57
Problem with libsqlite3.dylib on OSX
« on: April 17, 2019, 10:20:55 pm »
Hi,

I have a project, its 64bit, uses SQLite and works perfectly Ok if compiled with a bog standard Lazarus v2.0.0.

However, with rev 60971 .... if I do a Clean & Build, Run with or without Debug.. It errors with "Can not load SQLite Client library "libsqlite3.dylib". Check you installation"

As I said, works perfectly Ok if compiled with a bog standard Lazarus v2.0.0. so the library does exist, in the correct place

Anyone have any ideas?


Heres what I have ...

OS: OSX High Sierra 10.13.6
Lazarus: 2.0.0 (2019-03-07) - as reported by Help|About

Widgetset: Cocoa
Target: 64bit OSX

Compiler:
FPC 3.0.4 [2017/11/26] for x86_64

Debug:
LLDB  (with fpdebug)(Beta)
Path: /usr/bin/lldb
Version: lldb-1000.11.38.2



Cheers
OS: OSX High Sierra 10.13.6
Lazarus: 2.1.0, r61162

Widgetset: Cocoa
Target: 64bit OSX

Compiler:
FPC 3.0.4 [2017/11/26] for x86_64

Debug:
LLDB  (with fpdebug)(Beta)
Path: /usr/bin/lldb
Version: lldb-1000.11.38.2

 

TinyPortal © 2005-2018