Recent

Author Topic: Error Installing lazarus-project_2.0.2-0_amd64 on Linux Minit  (Read 1335 times)

jdslk2019

  • Newbie
  • Posts: 3
hi i am trying to install Lazarus 2.0.2 on Linux Mint , but i am getting error, please refer to the images attach

Handoko

  • Hero Member
  • *****
  • Posts: 3095
  • My goal: build my own game engine using Lazarus

jdslk2019

  • Newbie
  • Posts: 3
Re: Error Installing lazarus-project_2.0.2-0_amd64 on Linux Minit
« Reply #2 on: April 17, 2019, 12:35:12 pm »
Thaks, but that link does not help
i am using Linux Minit

Handoko

  • Hero Member
  • *****
  • Posts: 3095
  • My goal: build my own game engine using Lazarus
Re: Error Installing lazarus-project_2.0.2-0_amd64 on Linux Minit
« Reply #3 on: April 18, 2019, 07:28:27 am »
I do not use Linux Mint, so not much I can say.

Please be patient, someone experience in Mint will come to help you.

Thaddy

  • Hero Member
  • *****
  • Posts: 8458
Re: Error Installing lazarus-project_2.0.2-0_amd64 on Linux Minit
« Reply #4 on: April 18, 2019, 08:01:22 am »
On mint there is a problem with dependencies that are otherwise satisfied in other distributions.
This is a known fact. Usually you can install the needed -dev packages by hand: after all the missing dependencies are advertised.
Mint is not as mint as it should be - for developers -. There are too many things left out.
This distribution is not well suited for developers although it is very good for end-users.

Anyway: all can be fixed, but it takes some effort from yourselves.
Read the manuals and if you are a professional get a proper education in computer science. Makes the forum a lot cleaner.


dbannon

  • Hero Member
  • *****
  • Posts: 600
    • tomboy-ng, a rewrite of the classic Tomboy
Re: Error Installing lazarus-project_2.0.2-0_amd64 on Linux Minit
« Reply #6 on: April 18, 2019, 01:16:01 pm »
OK, its its a dependencies issue, Zoran's model says we need to install, I quote -

sudo apt-get install build-essential
sudo apt-get install libgtk2.0-dev
sudo apt-get install libgdk-pixbuf2.0-dev

maybe try installing them and, tring again. AND, importantly, if its all good, lets update the wiki page !

And it would be pretty cool if we could see whats behind the 'details' link in those error images ...

Lazarus 1.8, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng

Handoko

  • Hero Member
  • *****
  • Posts: 3095
  • My goal: build my own game engine using Lazarus
Re: Error Installing lazarus-project_2.0.2-0_amd64 on Linux Minit
« Reply #7 on: April 18, 2019, 02:20:16 pm »

dbannon

  • Hero Member
  • *****
  • Posts: 600
    • tomboy-ng, a rewrite of the classic Tomboy
Re: Error Installing lazarus-project_2.0.2-0_amd64 on Linux Minit
« Reply #8 on: April 19, 2019, 03:10:32 am »
garlar27 has a list of dependencies, maybe it helps:

https://forum.lazarus.freepascal.org/index.php/topic,41524.msg288242.html#msg288242

Hmm, and a usefull list too. I guess we could just have a script that installs every library we get reports of being needed. You run it, if a package  is already installed, it does no harm, if not, it gets installed. We might end up with a 'few' unnecessary libraries but maybe thats a smaller price to pay than people having problems.  Most of the list is just -dev anyway, just header files usually.

With distros like Mint, where they have just chosen to not bundle some developer stuff its fine. But what about some more "out there" distros where the mainainers have chosen some alternative library and we risk a clash ? Hmm....

Anyway, lets hear from jdslk2019 to see if Zoran suggestion helps .....

Davo
Davo
Lazarus 1.8, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng

MichalMolhanec

  • Newbie
  • Posts: 1
Re: Error Installing lazarus-project_2.0.2-0_amd64 on Linux Minit
« Reply #9 on: April 25, 2019, 11:52:31 am »
Hi, I had exactly the same problem.
For some reasond the GUI deb installer (GDebi) was not able to install the fpc-laz deb package although it said so.
When I used the command line
sudo apt install ./fpc-laz_3.0.4-1_amd64.deb
sudo apt install ./fpc-src_3.0.4-2_amd64.deb
sudo apt install ./lazarus-project_2.0.2-0_amd64.deb

it went well and Lazarus is now succesfully installed.

Handoko

  • Hero Member
  • *****
  • Posts: 3095
  • My goal: build my own game engine using Lazarus
Re: Error Installing lazarus-project_2.0.2-0_amd64 on Linux Minit
« Reply #10 on: April 25, 2019, 12:16:31 pm »
GDebi in recent versions of Ubuntu have problem installing the Lazarus deb packages. You still can use GDebi to install Lazarus, but you have to:

1. Run GDebi using sudo:
sudo gdebi-gtk

2. On GDebi menu > File > Open > choose the deb file > Install Package

dbannon

  • Hero Member
  • *****
  • Posts: 600
    • tomboy-ng, a rewrite of the classic Tomboy
Re: Error Installing lazarus-project_2.0.2-0_amd64 on Linux Minit
« Reply #11 on: April 26, 2019, 11:38:32 pm »
Hi, I had exactly the same problem.
For some reasond the GUI deb installer (GDebi) was not able to install the fpc-laz deb package although it said so.
When I used the command line
sudo apt install ./fpc-laz_3.0.4-1_amd64.deb
sudo apt install ./fpc-src_3.0.4-2_amd64.deb
sudo apt install ./lazarus-project_2.0.2-0_amd64.deb

it went well and Lazarus is now succesfully installed.

The problem with apt install is it does not resolve dependencies. Now, perhaps you did not not have any unmet dependencies or perhaps your unsuccessful gdebi run solved them. And perhaps you might still have unresolved dependencies and just not hit them yet. There is an apt command that will resolve any unmet dependencies after an install, cannot remember ....

Handoko, what does gdebi do wrong ?  Seems to be working fine for me recently ?   We really should try and work out what the problem is and report it.

Davo
Lazarus 1.8, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng

incendio

  • Jr. Member
  • **
  • Posts: 90
Re: Error Installing lazarus-project_2.0.2-0_amd64 on Linux Minit
« Reply #12 on: May 02, 2019, 10:52:49 am »
Try this :

https://forum.lazarus.freepascal.org/index.php/topic,45261.0.html

I got the same error, but now, it was solved.

lucamar

  • Hero Member
  • *****
  • Posts: 1942
Re: Error Installing lazarus-project_2.0.2-0_amd64 on Linux Minit
« Reply #13 on: May 02, 2019, 12:42:42 pm »
The problem with apt install is it does not resolve dependencies.

Huh? IIRC, that's not true: apt (and apt-get) do resolve and install (previous confirmation) any dependencies (included, config dependent, "recomended" and "suggested") of the package you're installing. The one who installs just the package you tell him is dpkg.
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus 2.0.2/2.0.4  - FPC 3.0.4 on:
(K|L)Ubuntu 12..16, Windows XP SP3, various DOSes.

dbannon

  • Hero Member
  • *****
  • Posts: 600
    • tomboy-ng, a rewrite of the classic Tomboy
Re: Error Installing lazarus-project_2.0.2-0_amd64 on Linux Minit
« Reply #14 on: May 02, 2019, 03:08:23 pm »
Yes, you are quite correct lucamar, a very careless post on my part
Davo
Lazarus 1.8, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng