Recent

Author Topic: Target OSX version has no effect using Download of Lazarus From Link  (Read 277 times)

josh

  • Hero Member
  • *****
  • Posts: 737
Hi

Just installed lazarus and fpc from link on main site, so have 2.0.0 and 3.0.4

I am running osx 10.13, i can compile and run a hello world app, runs fine on 10.13 and 10.14 but nothing prior to 10.13.
I have added in -WM10.8 in custom options.

If I then change custom option to -WM10.14, thinking now it should not run on my 10.13, but his has no effect.

It is as though it is compiling it for current development machione os and greater.

After each test, i have deleted the app bundle and re-created it, there is no change in the app bundle and no extra lines lines added to the info.plist file, i would assume it should aslo add in the  LSMinimumSystemVersion entry in.

ANy one any ideas as to what is happening,
Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.

josh

  • Hero Member
  • *****
  • Posts: 737
Re: Target OSX version has no effect using Download of Lazarus From Link
« Reply #1 on: April 02, 2019, 09:18:58 am »
Update

When I click Project Options SHow Options, the custom option is not added in.

So Itry to add the -WM option in Project Options All Options button, and putting 10.14 or 10.  in that box, press ok. But this is not saved, as if I go back to All Options the entry is blank again.

Any ideas as to how to add the -WM10.xxx option in, as it is not appearing in the list Show Options Dialog, if entered in cutom options or added in All Options.
Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.

josh

  • Hero Member
  • *****
  • Posts: 737
Re: Target OSX version has no effect using Download of Lazarus From Link
« Reply #2 on: April 02, 2019, 10:23:51 am »
UPDATE  Possible Working  NEEDS others to test.

Downloaded latest trunk for carbon exhibits the same.

However, If I add -WM10.8 Dorectly in Options then it appears to work, note I had to delete the application bundle, and re-create it so as to remove OSX caching. But when I set to 10.14 I did get the error not compatible with my 10.13, setting to 10. works on 10.13,10.14 and 10.8

Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.