Recent

Author Topic: Problem with Lazreport on OSX  (Read 1222 times)

corpusgemini

  • New Member
  • *
  • Posts: 16
Problem with Lazreport on OSX
« on: March 29, 2019, 08:48:25 am »
Hello,

I use Lazreport in an application that is compiled for both Windows 10 and OSX 64bit.
When printing out the report on OXS, something goes strangely wrong and the report is printed only partially, backwards and upside down.
On Windows, there is no problem at all.
This error is already visible when I do a print preview.

Any idea what can cause this?

Thanks,
Tony

jesusr

  • Sr. Member
  • ****
  • Posts: 470
Re: Problem with Lazreport on OSX
« Reply #1 on: March 30, 2019, 09:27:16 am »
What Lazarus version (and revision if you compile it yourself) do you have? Carbon? Cocoa?
« Last Edit: March 30, 2019, 09:36:52 am by jesusr »

corpusgemini

  • New Member
  • *
  • Posts: 16
Re: Problem with Lazreport on OSX
« Reply #2 on: April 01, 2019, 09:58:16 am »
I use OSX High Sierra, Lazarus 2.0.0 and compiled on Carbon; application also compiled on Carbon.
I noticed that when the application is compiled on Cocoa, Lazreport does not seem to work at all. 

corpusgemini

  • New Member
  • *
  • Posts: 16
Re: Problem with Lazreport on OSX - Solved
« Reply #3 on: April 02, 2019, 05:52:22 pm »
Hello,

I managed to solve the problem. The application was compiled to 32bit whereas the printer drivers are 64 bit.
I changed fpc to 64bit version and now the application runs with cocoa 64bit.
Printing is working ok now.

Best regards,
Tony