Recent

Author Topic: Ubuntu: Failed to load module "canberra-gtk-module"  (Read 1680 times)

stem

  • Jr. Member
  • **
  • Posts: 57
Ubuntu: Failed to load module "canberra-gtk-module"
« on: February 27, 2019, 09:11:59 pm »
Hi,

I have an application built with Linux Mint 19.1 (gtk2). When I copy the executable to
a system with a fresh install of Ubuntu 18.04 and start it in a terminal, I get the message

Code: Pascal  [Select]
  1. Gtk-Message: 21:02:50.761: Failed to load module "canberra-gtk-module"

The program starts and behaves normally.

In order to make the message disappear, I must run

Code: Pascal  [Select]
  1. sudo apt install libcanberra-gtk-module

Can I ignore the message?

Thank you.


stem

lucamar

  • Hero Member
  • *****
  • Posts: 1942
Re: Ubuntu: Failed to load module "canberra-gtk-module"
« Reply #1 on: February 27, 2019, 10:10:32 pm »
Hmmm ... I think you can ignore it but it's symptomatic of a problem in the Ubuntu configuration. Libcanberra is used to translate signals to event sounds and should have been installed automatically. This is what my system says about libcanberra-gtk-module:
Code: Bash  [Select]
  1. lucamar@selene:~$ aptitude show libcanberra-gtk-module
  2. Paquete: libcanberra-gtk-module
  3. Estado: instalado
  4. [...other info...]
  5. Descripción: translates GTK+ widgets signals to event sounds
  6.  A GtkModule which will automatically hook into all kinds of events inside a GTK+ program and generate sound events from them.
  7. lucamar@selene:~$ aptitude why libcanberra-gtk-module
  8. i   libcanberra-gtk0 Recommends libcanberra-gtk-module
  9. lucamar@selene:~$ aptitude why libcanberra-gtk0
  10. i   metacity Depends libcanberra-gtk0 (>= 0.2)
  11. lucamar@selene:~$ aptitude why metacity
  12. i   unity-2d Depends metacity (>= 1:2.34.1-1ubuntu8)
  13. lucamar@selene:~$ aptitude why unity-2d
  14. i   ubuntu-desktop Depends unity-2d

Note: You can ignore the step-reference to unity-2d; it's just an artifact introduced by an update.
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus 2.0.2/2.0.4  - FPC 3.0.4 on:
(K|L)Ubuntu 12..16, Windows XP SP3, various DOSes.