Recent

Author Topic: [Solved] TRichMemo - Hyperlinks not working  (Read 630 times)

OLLI_S

  • Full Member
  • ***
  • Posts: 111
[Solved] TRichMemo - Hyperlinks not working
« on: February 27, 2019, 05:06:43 pm »
Hello,

I am using Lazarus 1.8.4 in Windows 10 Professional x64.
I know that Lazarus 2.0 is out now, just had no time to install...

In my Lazarus application I have a TRichMemo component.
I composed the text in Microsoft Word 2016 and saved it as RTF file.
In my TRichMemo I selected the property "RTF" and loaded the file.

My text contains also an hyperlink.
The URL is fully shown in the document, in Word I selected it and added a hyperlink with the same URL.

In Word I can open the website by clicking <Ctrl>+Mouse-Click.
When I save my document as PDF then the link is also working.
But in my application the link is not working (it is not displayed as link and it is also not clickable).

When I loaded the RTF file in the property "RTF" of the TRichMemo component, then the "Rich Text Edit Dialog" is shown.
After loading the text is displayed as link (blue and underlined) but as soon as I click "OK" the hyperlink is removed.

I don't want to use an HTML component here, because editing the text in Word is very comfortable.

So how can I make the hyperlink working?
Thank you!

Best regards

OLLI
« Last Edit: March 02, 2019, 03:43:10 pm by OLLI_S »

OLLI_S

  • Full Member
  • ***
  • Posts: 111
Re: TRichMemo - Hyperlinks not working
« Reply #1 on: March 02, 2019, 03:42:57 pm »
Hello,

I am using an THtmlViewer now and here Hyperlinks are working.
So the issue is solved.

Best regards

OLLI