Recent

Author Topic: Error opening options  (Read 1128 times)

ericgc

  • Newbie
  • Posts: 2
Error opening options
« on: February 18, 2019, 03:42:26 am »
Hello everyone, I just installed Lazarus for Ubuntu 18.10 by the command: sudo apt-get install Lazarus. After opening the program and clicking Tools> Options an error message appears.

"Access Violation.
Press OK to ignore and risk data corruption.
Press abort to kill the program "

And when I click on "OK" the options window appears but with another error message:

"GetMainWidget Widget = nil.
Press OK to ignore and risk data corruption.
Press abort to kill the program "

The version of the installed system is in the attached images.

I have already uninstalled and installed the program and the error persists.

Thank you

dbannon

  • Hero Member
  • *****
  • Posts: 600
    • tomboy-ng, a rewrite of the classic Tomboy
Re: Error opening options
« Reply #1 on: February 18, 2019, 03:54:29 am »
Oh, Ericgc, thats a bad start  !

While I am sure we could, one way or another get to the bottom of that problem, there may be a better option.  You have installed version 1.8.4 of Lazarus, version 2.0.0 has been released and I think you will be better off getting the new one.

Please have a look at http://wiki.freepascal.org/Installing_Lazarus_on_Linux

If you decide to go ahead with that model, you will have to uninstall the existing Lazarus, FPC-Source and FPC. Most important !  Use the apt commands or something like Synaptic, if you have the (Ubuntu) Software Centre, I strongly recommend installing Synaptic and gdebi.

Davo
Lazarus 1.8, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng

ericgc

  • Newbie
  • Posts: 2
Re: Error opening options
« Reply #2 on: February 22, 2019, 06:09:03 am »
Hello dbannon.

I was able to solve following some of its guidelines, I did the following:

- I uninstalled all versions and dependencies of the lazarus and cleaned the previous installation folders.
- I downloaded all the dependencies of the site https://sourceforge.net/projects/lazarus/files/Lazarus%20Linux%20amd64%20DEB/Lazarus%202.0.0 and installed the packages in the following order:

1. fpc-laz_3.0.4-1_amd64.deb
2. fpc-src_3.0.4-2_amd64.deb
3. lazarus-project_2.0.0-0_amd64.deb

After these procedures the Lazarus 2.0 IDE opened normally.
I hope this tip also works for the other forum members if this happens.

Thanks for the help dbannon.

dbannon

  • Hero Member
  • *****
  • Posts: 600
    • tomboy-ng, a rewrite of the classic Tomboy
Re: Error opening options
« Reply #3 on: February 22, 2019, 01:22:58 pm »
in fact you could have left the dependencies there, would have saved a bit of time and bandwidth  :)

I'm pleased you are under way !

davo
Lazarus 1.8, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng