Author Topic: TSpinEdit bug?  (Read 5343 times)


  • Sr. Member
  • ****
  • Posts: 268
TSpinEdit bug?
« on: February 02, 2019, 09:50:54 pm »

Using fpc 3.0.5-r39845 [2019/02/02] from fixes_0, lazarus 1.8.5 r59122 from fixes_1_8

I open a new project. Put only a single TSpinEdit component on form. Set it to cross compile for WinCE-arm and when I run application on handheld I get error displayed. Below is debug.log file and attached is a project to reproduce the problem.
Code: [Select]
TApplication.HandleException TWinControl.WMMove loop detected: SpinEdit1:TSpinEdit BoundsRealized=l=54,t=31,r=128,b=50 NewBoundsRealized=l=110,t=31,r=184,b=50
  Stack trace:
If I press OK button, application runs. No more problems.

Can anybody confirm if you also have same error displayed, please?

Thanks & regards,
Ertan Küçükoğlu


  • Sr. Member
  • ****
  • Posts: 268
Re: TSpinEdit bug?
« Reply #1 on: February 06, 2019, 10:50:02 am »
I confirm that problem is solved in:
Lazarus 2.0.1 (fixes_2_0 branch, rev: 60339)
fpc 3.2.0 beta (fixes_3_2 branch rev: 41227)

Thanks to everyone for their continuing support.


TinyPortal © 2005-2018