Recent

Author Topic: ZEOS Installation fails on recent trunk  (Read 1155 times)

sierdolg

  • New Member
  • *
  • Posts: 18
ZEOS Installation fails on recent trunk
« on: January 31, 2019, 11:01:23 am »
If you try to install Lazraus-trunk and the module "zeos" using "fpcupdeluxe", recently it fails with the following message:

Code: Pascal  [Select]
  1. .../lazarus/trunk-trunk/ccr/zeos/src/plain/ZPlainFirebirdDriver.pas(123,28) Error: (5042) No matching implementation for interface method "Initialize(const AnsiString);" found
  2. .../lazarus/trunk-trunk/ccr/zeos/src/plain/ZPlainFirebirdDriver.pas(427,1) Fatal: (10026) There were 1 errors compiling module, stopping
  3. Fatal: (1018) Compilation aborted
  4. Error: /mnt/harddisk1.../lazarus/trunk-trunk/fpc/bin/x86_64-linux/ppcx64 returned an error exitcode
  5. Error: (lazarus) Compile package zplain 7.3: stopped with exit code 1
  6. Error: (lazarus) [TLazPackageGraph.CompileRequiredPackages] "Exit code 1"
  7. Error: (lazarus) Building IDE: Compile AutoInstall Packages failed.

The lines complained about are:

Code: Pascal  [Select]
  1.  TZInterbasePlainDriver = class (TZAbstractPlainDriver, IZInterbasePlainDriver)
  2.   private
  3.     FCodePageArray: TWordDynArray;
  4.   protected
  5.     FPreLoader : TZNativeLibraryLoader;
  6.     procedure FillCodePageArray;
  7.     procedure LoadCodePages; override;
  8.     function GetUnicodeCodePageName: String; override;
  9.     {$IFDEF ENABLE_INTERBASE_CRYPT}
  10.     procedure Initialize; virtual;
  11.     {$ENDIF}
  12.     procedure LoadApi; override;
  13.   public
  14.     constructor Create;
  15.     {$IFDEF ENABLE_INTERBASE_CRYPT}
  16.     destructor Destroy; override;
  17.     {$ENDIF}
  18.     function GetCodePageArray: TWordDynArray;
  19.  

Hints given are:
Code: Pascal  [Select]
  1. Compile package zplain 7.3: Exit code 1, Errors: 1, Warnings: 1
  2. ZPlainFirebirdDriver.pas(132,15) Warning: An inherited method is hidden by "Initialize;"
  3. ZPlainFirebirdDriver.pas(123,28) Error: No matching implementation for interface method "Initialize(const AnsiString);" found
  4. Compile package zparsesql 7.3: Aborted
  5.  

Can anybody shed a light on what is going wrong here? The module compiles well in "stable-stable", so a programming error in the narrower sense is unlikely.

The goal would be to find out what adjustment(s) is/are necessary...

System is KDE Neon (Ubuntu 18.04 based), 64 bit.
fpcupdeluxe Version used 1.6.2j (also tried elder ones with identical result).
« Last Edit: January 31, 2019, 11:34:40 am by sierdolg »