Recent

Author Topic: lazarus error, need help  (Read 24845 times)

freebsduser

  • Guest
lazarus error, need help
« on: August 24, 2004, 11:47:09 am »
I have install all version lazarus release with fpc on freebsd 4.10 or freebsd 5.21but get same error.
ftp://pub.dec.cn/error.png

alert: error in Tdefaultcomponenteditor

message:unit not fount:SYSTEM

Anonymous

  • Guest
lazarus error, need help
« Reply #1 on: August 24, 2004, 11:57:56 am »
What version of lazarus and what version of fpc are you using.
from the message "message:unit not fount:SYSTEM" it looks like you have a different version of fpc than that of lazarus is compiled with

Marc

  • Administrator
  • Hero Member
  • *
  • Posts: 2557
lazarus error, need help
« Reply #2 on: August 24, 2004, 11:59:32 am »
Grrr.... somehow I got logged out. Previous message from me.
//--
{$I stdsig.inc}
//-I still can't read someones mind
//-Bugs reported here will be forgotten. Use the bug tracker

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2661
    • My Lazarus wiki user page
lazarus error, need help
« Reply #3 on: August 24, 2004, 12:04:15 pm »
Did you install the fpc sources? If so, did you install them in /root/Desktop/fpc? Correct the fpc source directory in the Envrionment, Environment Options, Files tab, if necessary. Try Environment, Rescan FPC directory.

Anonymous

  • Guest
lazarus error, need help
« Reply #4 on: August 24, 2004, 12:10:01 pm »

Marc

  • Administrator
  • Hero Member
  • *
  • Posts: 2557
lazarus error, need help
« Reply #5 on: August 24, 2004, 12:21:15 pm »
This image is not different tha the first one.  We need more info to help you
//--
{$I stdsig.inc}
//-I still can't read someones mind
//-Bugs reported here will be forgotten. Use the bug tracker

Anonymous

  • Guest
lazarus error, need help
« Reply #6 on: August 24, 2004, 12:25:00 pm »
I have install :
fpcsrc-1.9.5-040821.tgz with  Lazarus 0.9.2.0( lazarus-040822.tgz)  on freebsd 5.21 /4.10
lazarus-0.9.1.4 with fpc_1.9.3 on freebsd 5.21 /4.10
lazarus0.9.1.2 with fpc 1.9.3 on freebsd 4.10
lazarus-0.9.0.8 and fpc_1.9.2_040106. on freebsd 4.10
get same error as above screenshot
I don't know how to fix it,so I deinstall and  reinstall many times  . thinks.

Marc

  • Administrator
  • Hero Member
  • *
  • Posts: 2557
lazarus error, need help
« Reply #7 on: August 24, 2004, 12:36:49 pm »
from https://sourceforge.net/project/showfiles.php?group_id=89339&package_id=93718

you need all 3 links listed under lazarus 0.9.2.0

so if you want the lazarus binary from lazarus-040822.tgz you need a compiler and compiler source version fpc_1.9.5_040808  

If you want to build lazarus yourself, the fpc version and fpc source version needs to be the same.
//--
{$I stdsig.inc}
//-I still can't read someones mind
//-Bugs reported here will be forgotten. Use the bug tracker

Anonymous

  • Guest
lazarus error, need help
« Reply #8 on: August 24, 2004, 12:53:05 pm »
I  have install fpc sources and set Environment Options->fpc source directory to "/root/Desktop/fpc "(I am decompressing fpcsrc package file there and install it)
I can using lazarus open examples project and compile them without error,but I can't edit new button(or other component  I drop to form) envents procedure code. if I double click the button component  ,It alert "error in Tdefaultcomponenteditor " msgbox as screenshot.

Anonymous

  • Guest
lazarus error, need help
« Reply #9 on: August 24, 2004, 01:09:22 pm »
I built fpc_1.9.5-src using fpc 1.0.10 compiler ,then  built lazarus 0.9.2.0-src using fpc_1.9.5 compiler , and then rebuilt fpc_1.9.5-src with fpc_1.9.5 compiler .something wrong?

Marc

  • Administrator
  • Hero Member
  • *
  • Posts: 2557
lazarus error, need help
« Reply #10 on: August 24, 2004, 01:32:34 pm »
This looks good.
Did you try Environment, Rescan FPC directory ?
//--
{$I stdsig.inc}
//-I still can't read someones mind
//-Bugs reported here will be forgotten. Use the bug tracker

Anonymous

  • Guest
lazarus error, need help
« Reply #11 on: August 24, 2004, 02:19:44 pm »
yes ,I do it ,but no error message.

Marc

  • Administrator
  • Hero Member
  • *
  • Posts: 2557
lazarus error, need help
« Reply #12 on: August 24, 2004, 02:22:34 pm »
What do you have configured as compiler in environment options ? (path to fpc)
//--
{$I stdsig.inc}
//-I still can't read someones mind
//-Bugs reported here will be forgotten. Use the bug tracker

Anonymous

  • Guest
lazarus error, need help
« Reply #13 on: August 24, 2004, 03:32:11 pm »
I hace configured  environment options->
 fpc compiler path ->/usr/local/bin/ppc386  //run ppc386 -i    version is 1.95  
 fpc src  path  -> fpc_1.9.5-src directory  where i build fpc_1.9.5 compiler.
Lazarus can compile and run  anything(in exampels) fast  without error,I sure  environment configure is correct.

Marc

  • Administrator
  • Hero Member
  • *
  • Posts: 2557
lazarus error, need help
« Reply #14 on: August 24, 2004, 04:38:37 pm »
Environment is not used when compiling examples. Environment is for lazarus itself.

I now see something strange in your picture:
Lazarus is complaining that while pasing the file /root/Desktop/fpc/fcl/classes/freebsd/classes.pp it cannot find system. But in fpc 1.9.5 the classes dir is moved to the rtl.
So that sould be /root/Desktop/fpc/rtl/objpas/classes

What version of sources do you have ? Have you installed different versions in the same location ?
//--
{$I stdsig.inc}
//-I still can't read someones mind
//-Bugs reported here will be forgotten. Use the bug tracker

 

TinyPortal © 2005-2018