Recent

Author Topic: I need help installing OPENGPSX component for Lazarus  (Read 837 times)

Awesome Programmer

  • Sr. Member
  • ****
  • Posts: 415
  • Programming is FUN only when it works :)
    • Cool Technology
I need help installing OPENGPSX component for Lazarus
« on: January 03, 2019, 08:29:51 pm »
Lazarus 1.0.12
fpc 2.6.2
opengpsx 0.3.23
sdposeriallaz 0.1.5
Operating System is Linux (Mageia)

I am trying to install open gps component for lazarus, but it is giving me issues. First, it complained that it can't find FileUtil and I fixed that. Then, it said it needs sdpo serial for lazarus. Then, I downloaded that and try to install it. However, it too is having issue(s). It says, Fatal: Can't find unit sdposerial used by sdposeriallaz... I can't seem to find a fix or solution for this.

Any help will be greatly appreciated. Thank you.
« Last Edit: January 03, 2019, 08:37:52 pm by Awesome Programmer »

wp

  • Hero Member
  • *****
  • Posts: 5723
Re: I need help installing OPENGPSX component for Lazarus
« Reply #1 on: January 03, 2019, 08:53:21 pm »
Your Lazarus and fpc versions are ancient... I don't know whether these package still compile with such old versions.

You should update to the current release versions, currently Laz 1.8.4/fpc 3.0.4. Here you'll find the Online Package Manager (OPM) where you only have to set a checkmark to the OpenGPSX package, and OPM will do all the work; it will even install the required packages. It works - I just tested it.

OPM is not installed by default. Go to Package > Install/Uninstall packages, select "OnlinePackageManager" in the right list, click "Install selection" and "Save and Build IDE"
« Last Edit: January 03, 2019, 08:55:21 pm by wp »
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

Awesome Programmer

  • Sr. Member
  • ****
  • Posts: 415
  • Programming is FUN only when it works :)
    • Cool Technology
Re: I need help installing OPENGPSX component for Lazarus
« Reply #2 on: January 03, 2019, 09:38:59 pm »
Hi wp,

it looks like the latest version in my repository for lazarus is 1.0.12. So, can I manually download lazarus from lazarus website and install it.

wp

  • Hero Member
  • *****
  • Posts: 5723
Re: I need help installing OPENGPSX component for Lazarus
« Reply #3 on: January 03, 2019, 09:43:16 pm »
It is probably easiest to use fpcupdeluxe for getting current Laz and fpc versions on Linux (https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases).
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

Awesome Programmer

  • Sr. Member
  • ****
  • Posts: 415
  • Programming is FUN only when it works :)
    • Cool Technology
Re: I need help installing OPENGPSX component for Lazarus
« Reply #4 on: April 09, 2019, 09:29:02 pm »
The best thing to do is simply upgrade to the latest and the greatest and that's just what I had to do and did.

The latest Lazarus has a Online Package Manager. It has all the latest tools and components. I love it.