Bookstore

Recent

Author Topic: rte 216 with fpc 1.9.5  (Read 30147 times)

seeb

  • Guest
rte 216 with fpc 1.9.5
« on: August 23, 2004, 10:36:20 am »
Hi all,

I got the latest sources of lazarus and fpc from cvs.
I did a make win32zip and installed the new compiler from the resulting zips.

Now "make clean all" in lazarus dir brings up a runtime error 216 while
compiling lazlinkedlist.pas

Any ideas whats wrong?

Bye

seeb

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2661
    • My Lazarus wiki user page
rte 216 with fpc 1.9.5
« Reply #1 on: August 23, 2004, 01:53:26 pm »
You might want to try and get the very latest fpc 1.9.5. I have reports this has been fixed.

pepecito

  • Full Member
  • ***
  • Posts: 130
    • http://pepecito.zapto.org
rte 216 with fpc 1.9.5
« Reply #2 on: August 23, 2004, 07:20:56 pm »
Having the fpc 1.9.4 what is the standard procedure to get the 1.9.5 compiled? I'm asking this because it seems that I can't get the 1.9.5 compiled or installed properly.
:: Home Page ::

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2661
    • My Lazarus wiki user page
rte 216 with fpc 1.9.5
« Reply #3 on: August 23, 2004, 07:35:40 pm »
The standard procedure to build fpc 1.9.5 is to use a fpc 1.0.10 compiler. It might work with fpc 1.9.4 too.

Roughly it goes like this:

goto the fpc 1.9.5 source directory (the one with compiler, rtl, packages, fcl).
make all PP=<path-to-ppc386.exe from 1.0.10>
make install

See for more details: http://www.stack.nl/~marcov/buildfaq.pdf

mschnell

  • Full Member
  • ***
  • Posts: 131
    • http://www.lumino.de
rte 216 with fpc 1.9.5
« Reply #4 on: August 24, 2004, 08:48:01 am »
Re "make":

c:\lazarus>make -v
GNU Make 3.80

it sais:

Makefile:27: *** You need the GNU utils package to use this Makefile.  Stop.



Re: Lazarus menu "tools->build lazarus":

Is this not supposed to work in some way ?

-Michael

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2661
    • My Lazarus wiki user page
rte 216 with fpc 1.9.5
« Reply #5 on: August 24, 2004, 09:55:05 am »
Quote
Re "make":

c:\lazarus>make -v
GNU Make 3.80

it sais:

Makefile:27: *** You need the GNU utils package to use this Makefile. Stop.

Strange. What happens if you do:
c:\lazarus>pwd
Quote
Re: Lazarus menu "tools->build lazarus": Is this not supposed to work in some way ?


Yes, it is suposed to work. There are several problems on win32.
- make must be on the path. This is generally the case in *nix, but not in windows (in the current cvs version, you can set the make executable in the environment options)
- build lazarus overwrites lazarus.exe. If you are running lazarus.exe, you can't overwrite it in win32 (*nix can overwrite running executables).
- The process creations was not working perfect and build lazarus would stop after some make invocations. This has been fixed in the current CVS version of the FCL (not part of lazarus, but of fpc).

mschnell

  • Full Member
  • ***
  • Posts: 131
    • http://www.lumino.de
rte 216 with fpc 1.9.5
« Reply #6 on: August 24, 2004, 10:17:16 am »
Quote
Strange. What happens if you do:
c:\lazarus>pwd


"unknown command pwd"


Quote
Re: Lazarus menu "tools->build lazarus": Is this not supposed to work in some way ?

Yes, it is suposed to work. There are several problems on win32.

- make must be on the path. This is generally the case in *nix, but not in windows (in the current cvs version, you can set the make executable in the environment options)


gnu make is on the path

Quote
- build lazarus overwrites lazarus.exe. If you are running lazarus.exe, you can't overwrite it in win32 (*nix can overwrite running executables).


I did try renaming it and execute it afterwards: no change

Quote
- The process creations was not working perfect and build lazarus would stop after some make invocations. This has been fixed in the current CVS version of the FCL (not part of lazarus, but of fpc).


The funny thing is that it does not even start.

Thanks for caring !
-Michael

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2661
    • My Lazarus wiki user page
rte 216 with fpc 1.9.5
« Reply #7 on: August 24, 2004, 11:28:20 am »
Quote
Quote

Strange. What happens if you do:
c:\lazarus>pwd

"unknown command pwd"

It seems you are missing some helper utilities, like pwd and maybe windres, as and ld.
Normally they are installed with fpc in its bin directory. They need to be on the path or in the same directory as make.

pepecito

  • Full Member
  • ***
  • Posts: 130
    • http://pepecito.zapto.org
rte 216 with fpc 1.9.5
« Reply #8 on: August 24, 2004, 11:42:31 am »
fpcsrc-1.9.5-040821.tgz hasn't these utilities. I got them from the previous release.
:: Home Page ::

pepecito

  • Full Member
  • ***
  • Posts: 130
    • http://pepecito.zapto.org
rte 216 with fpc 1.9.5
« Reply #9 on: August 24, 2004, 11:49:18 am »
Quote from: "Vincent"
The standard procedure to build fpc 1.9.5 is to use a fpc 1.0.10 compiler. It might work with fpc 1.9.4 too.


I got it to be compiled with the 1.9.4 simply by typing
make install
but it used c:/pp as base directory while I was working in c:/fpc. So I had to rename the result directory (maybe there is a way to set the output directory withput renaming it later).

After that I succesfully compiled the latest lazarus snapshot!  :P
:: Home Page ::

mschnell

  • Full Member
  • ***
  • Posts: 131
    • http://www.lumino.de
rte 216 with fpc 1.9.5
« Reply #10 on: August 24, 2004, 05:12:47 pm »
Quote

It seems you are missing some helper utilities, like pwd and maybe windres, as and ld.
Normally they are installed with fpc in its bin directory. They need to be on the path or in the same directory as make.


Right . pp\bin\win32 was not in the path.

Now I can start make.  After some lines of output I get:


Compiling lresources.pp
lresources.pp(95,14) Error: There is no method in an ancestor class to be overridden: "TLRSObjectReader.ReadCurrency:Currency"
lresources.pp(107,14) Error: There is no method in an ancestor class to be overridden: "TLRSObjectReader.ReadWideString:WideString"
lresources.pp(160,15) Error: There is no method in an ancestor class to be overridden: "TLRSObjectWriter.WriteCurrency(const Currency)"
lresources.pp(169,15) Error: There is no method in an ancestor class to be overridden: "TLRSObjectWriter.WriteWideString(const WideString)"
lresources.pp(255,1) Fatal: There were 4 errors compiling module, stopping
MAKE[1]: *** [alllclunits.ppu] Error 1
MAKE[1]: Leaving directory `/cygdrive/c/lazarus/lcl'
MAKE: *** [lcl] Error 2


What's wrong now ?

-thanks, Michael

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2661
    • My Lazarus wiki user page
rte 216 with fpc 1.9.5
« Reply #11 on: August 24, 2004, 05:35:16 pm »
This seems to suggest your are not using fpc 1.9.5 units.

Check the paths in the fpc.cfg file.
Or do make OPT="-va" to see what classes.ppu is used.

mschnell

  • Full Member
  • ***
  • Posts: 131
    • http://www.lumino.de
rte 216 with fpc 1.9.5
« Reply #12 on: August 25, 2004, 09:16:50 am »
After reinstalling Free Pascal 1.0.10 I was able to "make" Lazarus 0.9.2.

Lazarus starts and shows the IDE.

But all component pictures in the component library tabs are empy (invisible).

I can see an empty rectangle when I move the mouse on one picture or when I select on by clicking.

I even cann see the component name in the "hint" when moving the mouse on one.

What am I missing here ?

-Michael

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2661
    • My Lazarus wiki user page
rte 216 with fpc 1.9.5
« Reply #13 on: August 25, 2004, 09:34:27 am »
fpc 1.0.10 has a very basic image support. Lazarus needs the fpImage package to be of later date than februari/march 2004. The fpc 1.0.10 release is of June 2003. => too old.

mschnell

  • Full Member
  • ***
  • Posts: 131
    • http://www.lumino.de
rte 216 with fpc 1.9.5
« Reply #14 on: August 26, 2004, 01:27:51 pm »
I installed fpc 1.9.4. Now I get:

MAKE[1]: Entering directory `/cygdrive/c/lazarus'
windres -i lazarus.rc -o lazarus.res --preprocessor /cygdrive/c/PP/BIN/WIN32/cpp
.exe
Unknown command "ygdrive"
c:\PP\BIN\WIN32\windres.exe: warning: preprocessor failed
c:\PP\BIN\WIN32\windres.exe: no resources
MAKE[1]: *** [lazarus.res] Error 1
MAKE[1]: Leaving directory `/cygdrive/c/lazarus'
MAKE: *** [ide] Error 2



Thanks, Michael