Recent

Author Topic: Tedit with readonly set to true doesn't work  (Read 1790 times)

shogun

  • New member
  • *
  • Posts: 6
Tedit with readonly set to true doesn't work
« on: December 12, 2018, 04:43:32 pm »
Hello,

In lazarus 2.0.0RC2 running on OSX Sierra, when using a Tedit and set readonly to true I am still able to write in the tedit field.
If I switch to QT5 Widgetset, with the same program, the Tedit field is working in readonly mode, as expected.

Tried with lazarus 1.8.4, the same issue occurs.

Does anyone already had this problem too ?

Thanks

zeljko

  • Hero Member
  • *****
  • Posts: 1149
    • http://wiki.lazarus.freepascal.org/User:Zeljan
Re: Tedit with readonly set to true doesn't work
« Reply #1 on: December 12, 2018, 06:32:54 pm »
Best would be to try with trunk if it works , and if that's not the case then open an issue against cocoa widgetset.
If it works there maybe it's merged into fixes_2.0 so will be available in RC3.

shogun

  • New member
  • *
  • Posts: 6
Re: Tedit with readonly set to true doesn't work
« Reply #2 on: December 12, 2018, 09:53:19 pm »
Tried with trunk (2.1.0 r59806) and still have this problem with cocoa. Tried with carbon and it works fine.
Issue opened on lazarus bugtracker.
« Last Edit: December 12, 2018, 10:05:23 pm by shogun »

zeljko

  • Hero Member
  • *****
  • Posts: 1149
    • http://wiki.lazarus.freepascal.org/User:Zeljan
Re: Tedit with readonly set to true doesn't work
« Reply #3 on: December 13, 2018, 08:20:20 am »
Tnx

 

TinyPortal © 2005-2018