Recent

Author Topic: <SOLVED> INDY 10 And LAMW  (Read 5434 times)

freris

  • New Member
  • *
  • Posts: 43
  • A Retired hobbist programmer from Greece
Re: INDY 10 And LAMW
« Reply #15 on: December 05, 2018, 08:35:33 pm »
 Ok Remy

Thank you very much for your answers.

I will search the code again or I will go back to the older versions
As I get older, the more I learn !!

freris

  • New Member
  • *
  • Posts: 43
  • A Retired hobbist programmer from Greece
Re: INDY 10 And LAMW
« Reply #16 on: December 09, 2018, 07:27:23 pm »
Finally solved the problem myself.

The problem is that there is no backward compatibility of the new versions of the indy package.

They use the iconvec which is incompatible with the api 21 that has my phone. So I found the older indy version 10.2.0 and followed the steps below.

I did not change laz4android version 1.80.

I did not changed the latest version of LAMW.

I did not change version 3.0.4 of fpc.

I also had to have the indylaz package on the dependencies, but may not exist in their program uses. Is critical!

And everything worked as it should


I use the indy package for many years and it is very reliable. I did not want to use other internet packages

Thanks
As I get older, the more I learn !!

jmpessoa

  • Hero Member
  • *****
  • Posts: 1608
Re: INDY 10 And LAMW
« Reply #17 on: December 09, 2018, 08:01:40 pm »
Good!

Please, put here some simple    LAMW+ Indy  "demo"  !!

So,  I will  commit to the  LAMW  git repository...

Thank you!
« Last Edit: December 09, 2018, 08:14:03 pm by jmpessoa »
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

freris

  • New Member
  • *
  • Posts: 43
  • A Retired hobbist programmer from Greece
Re: INDY 10 And LAMW
« Reply #18 on: December 09, 2018, 08:05:13 pm »
Ok jmpessoa.

I will attach tomorrow a zip file with a sample project.

Thank you
As I get older, the more I learn !!

freris

  • New Member
  • *
  • Posts: 43
  • A Retired hobbist programmer from Greece
[Solved] - INDY 10 And LAMW
« Reply #19 on: December 10, 2018, 03:45:19 pm »
Hi.

I attach the dropbox link

https://www.dropbox.com/sh/diw045ywo768ehd/AAD1UzwOiIr83MTQisclclEPa?dl=0

that includes the sample of my project that uses indylaz and LAMW, I also include the indylaz package that is hard to find. And a screenshot showing which is placed the indylaz dependency.

Thank you
As I get older, the more I learn !!

Remy Lebeau

  • Hero Member
  • *****
  • Posts: 813
    • Lebeau Software
Re: INDY 10 And LAMW
« Reply #20 on: December 10, 2018, 08:53:02 pm »
The problem is that there is no backward compatibility of the new versions of the indy package.

They use the iconvec which is incompatible with the api 21 that has my phone.

In what way exactly?  Can you be more specific?  Indy does not use any of the Android APIs directly.  Indy operates at the native Linux POSIX layer that runs underneath Android's Java layer.  ICONV is a Linux native library, and iconvenc is a FPC provided unit.  In what way is it not compatible with Android?

So I found the older indy version 10.2.0 and followed the steps below.

That is an extremely old version of Indy, you really should not use it.  I'd rather understand why the latest version is not working for you so it can be fixed.
Remy Lebeau
Lebeau Software - Owner, Developer
Internet Direct (Indy) - Admin, Developer (Support forum)

freris

  • New Member
  • *
  • Posts: 43
  • A Retired hobbist programmer from Greece
Re: INDY 10 And LAMW
« Reply #21 on: December 10, 2018, 08:59:35 pm »
Thank you for your interest.

 I do not know many things about android and java.
Only pascal.

But as long as the work is done it does not matter.

Thank you very much.
As I get older, the more I learn !!

freris

  • New Member
  • *
  • Posts: 43
  • A Retired hobbist programmer from Greece
Re: <SOLVED> INDY 10 And LAMW
« Reply #22 on: December 17, 2018, 06:07:48 pm »
Hi again.

And to conclude and close this discussion, see what exactly is going on with my problem as mentioned in the relevant forum.

https://github.com/android-ndk/ndk/issues/702#issuecomment-391039098

Thank you
As I get older, the more I learn !!

bmcsoft

  • New member
  • *
  • Posts: 9
Re: INDY 10 And LAMW
« Reply #23 on: July 09, 2020, 09:28:42 am »
Finally solved the problem myself.

The problem is that there is no backward compatibility of the new versions of the indy package.

They use the iconvec which is incompatible with the api 21 that has my phone. So I found the older indy version 10.2.0 and followed the steps below.

How to compile last Indy10 for Android? Author of Indy do not recommend use 10.2.0 now.
If iconvenc is incompatible with the API 21, which version API working with it?

Someone can fix the iconvenc to working on all version of Android including API 21?


DonAlfredo

  • Hero Member
  • *****
  • Posts: 1330
Re: <SOLVED> INDY 10 And LAMW
« Reply #24 on: July 09, 2020, 10:06:55 am »
As I stumbled into the same issue some time ago, I just compiled iconv myself.
Both static libs and dynamic libs are available at the links. I would 100% recommend the static libs !

https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/download/1.6.8z/dynamiclibs.zip
https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/download/1.6.8z/staticlibs.zip

freris

  • New Member
  • *
  • Posts: 43
  • A Retired hobbist programmer from Greece
Re: <SOLVED> INDY 10 And LAMW
« Reply #25 on: July 09, 2020, 01:26:39 pm »
Thank you DonAlfredo.

I will try these libraries as soon as possible.

Thank's again
As I get older, the more I learn !!

bmcsoft

  • New member
  • *
  • Posts: 9
Re: <SOLVED> INDY 10 And LAMW
« Reply #26 on: July 09, 2020, 05:12:28 pm »
And to conclude and close this discussion, see what exactly is going on with my problem as mentioned in the relevant forum.
https://github.com/android-ndk/ndk/issues/702#issuecomment-391039098
I read this article and didn't find anything useful.

Quote
-Interesting... Does this mean that iconv is available in devices starting API 28?
-Yes
I've compiled and running last Indy10 application on Android9 (Genymotion), Android10 (real phone Xiaomi Mi9). It's crushing all time and doesn't work.

Quote
Will update Android NDK for r17b.
It doesn't work either.



bmcsoft

  • New member
  • *
  • Posts: 9
Re: <SOLVED> INDY 10 And LAMW
« Reply #27 on: July 09, 2020, 06:26:20 pm »
I would 100% recommend the static libs !

I put "libiconv.a" in a JNI-folder. Compiled successfully. On Android8 it's crashed when starting app.
On Android10 compiled application starts normally, but when I press jButton on the main form and dynamically create TIdUDPServer and trying to send packet - it's crashed also.

That is an extremely old version of Indy, you really should not use it.  I'd rather understand why the latest version is not working for you so it can be fixed.

I need to use Android7 and Android8 devices for my working app.
Should I use the old version Indy 10.2.0.3 anyway?

« Last Edit: July 09, 2020, 06:28:22 pm by bmcsoft »

Remy Lebeau

  • Hero Member
  • *****
  • Posts: 813
    • Lebeau Software
Re: <SOLVED> INDY 10 And LAMW
« Reply #28 on: July 09, 2020, 07:17:15 pm »
I've compiled and running last Indy10 application on Android9 (Genymotion), Android10 (real phone Xiaomi Mi9). It's crushing all time and doesn't work.

Can you be more specific?  Crashing HOW exactly?  What is the actual error message, and WHERE is it occurring?

On Android8 it's crashed when starting app.
On Android10 compiled application starts normally, but when I press jButton on the main form and dynamically create TIdUDPServer and trying to send packet - it's crashed also.

Again, HOW and WHERE is it crashing exactly?

Should I use the old version Indy 10.2.0.3 anyway?

NO, it is way too old.  The current version is 10.6.2.  A LOT has changed since 10.2.0.  I'm not going to provide support for such an old version.
« Last Edit: July 09, 2020, 07:21:03 pm by Remy Lebeau »
Remy Lebeau
Lebeau Software - Owner, Developer
Internet Direct (Indy) - Admin, Developer (Support forum)

Segator

  • Jr. Member
  • **
  • Posts: 97
    • https://github.com/Nenirey
Re: <SOLVED> INDY 10 And LAMW
« Reply #29 on: August 15, 2020, 09:35:15 pm »
the same problem with last indy version in android 10 with lamw, first when i try to build the application with idhttp and idssl... not compile because not found the iconvec library, i solve it coping the 3 libray file to the System indy folder, then when it build the app run good but when i start the ld http client the application it's closed with no error message.
i am Reinier, Nenirey and Segator :) https://github.com/Nenirey

 

TinyPortal © 2005-2018