Recent

Author Topic: Fast Report installation problem.  (Read 1925 times)

Kurush

  • New member
  • *
  • Posts: 5
Fast Report installation problem.
« on: December 03, 2018, 09:03:00 am »
Hi!

I am trying to install Fast Report components (version 6.2) in Ubuntu 18.04 operating system from source. I am using "fr6_lazarus.lpk" file. But I had an error while compiling "frxStorage.pas" file. It uses "Windows" module which is obviously absent at any Linux operating systems. Has anyone come across this problem? What should I do?

Thanks in advance for your response.

MacWomble

  • New member
  • *
  • Posts: 34
Re: Fast Report installation problem.
« Reply #1 on: December 03, 2018, 09:21:11 am »
Witch edition do you use?

If you bought Fast Report you should consolidate the support.
If free edition you should try also ...

It seems to be an error in the package, as it is declared as cross platform and linux compatible.

Mint 18.3 Cinnamon, Codetyphon 6.4 64Bit

Groffy

  • Full Member
  • ***
  • Posts: 203
Re: Fast Report installation problem.
« Reply #2 on: December 03, 2018, 09:21:52 am »
Hello,

did you already write a support ticket to FastReport? What happens when you comment out the Windows unit? I think there are some wrong compile switches set. 


Best regards
Linux Mint 18.3 - KDE / Windows8 / Lazarus 2.0.0 / trunk -qt

Kurush

  • New member
  • *
  • Posts: 5
Re: Fast Report installation problem.
« Reply #3 on: December 03, 2018, 10:30:03 am »
I have created a support ticket for FastReport. Commenting out the Windows unit generates a lot of new errors.

Groffy

  • Full Member
  • ***
  • Posts: 203
Re: Fast Report installation problem.
« Reply #4 on: December 03, 2018, 12:17:32 pm »
Commenting out the Windows unit generates a lot of new errors.

That was expectable, but you get a list of missing functions which must be in any of the frx units to replace the windows function under Linux

Best regards
Linux Mint 18.3 - KDE / Windows8 / Lazarus 2.0.0 / trunk -qt

Kurush

  • New member
  • *
  • Posts: 5
Re: Fast Report installation problem.
« Reply #5 on: December 03, 2018, 02:28:41 pm »
I have got an answer from FastReport. Version 6 for Linux is not supported by now. So they recommended using version 5.

tatamata

  • Hero Member
  • *****
  • Posts: 692
    • ZMSQL - SQL enhanced in-memory database
Re: Fast Report installation problem.
« Reply #6 on: March 02, 2019, 10:26:17 am »
What is current state of FastReports (commercial) compatibility with Lazarus/FreePascal?
Is it worthy of buying?

ps

  • Jr. Member
  • **
  • Posts: 75
Re: Fast Report installation problem.
« Reply #7 on: March 15, 2019, 05:30:30 pm »
It's really hard to tell. I have 5 and 6 version (commercial) currently trying it. For me most important new PDF export is not available for 6 version ... and answer from support don't look promising : "we don't know when FR 6 exports will be portedfor Lazarus" ...

maybe more Lazarus users help ? ...
IDE:  Lazarus 1.8 RC3/Trunk, Delphi XE OS:Windows 10, Ubuntu