Recent

Author Topic: Newby to Suse Leap  (Read 1197 times)

eraaijma

  • New member
  • *
  • Posts: 26
Newby to Suse Leap
« on: November 14, 2018, 02:51:19 pm »
I have installed Lazarus 64Bit on Suse: Works out of the box.
Connecting to Mariadb or Mysql I get a message however.
'LibMysqlClient.so.18 is missing'.

In Windows, I know exactly what to do (copy the rigth LibMySQL.dll to the correct directory)
In Linux, I am stuck. Mainly because I am no expert to this OS.

I see that in my documents files, a compiled version of my program is stored. Hence I thought to copy LibMysqlClient.so.18 there.
I encounter a problem though: I can only find libMySQL.RPM-files, not the Lib....so.18 file. If I doubleclick the RPM, 'something' happens, but I cannot find the installed package after installation.

Questions:
Could it be so simple as in Windows: copy one file to the right location and get going?
Is there maybe a standard way to install this library?

Thanks


lucamar

  • Hero Member
  • *****
  • Posts: 1814
Re: Newby to Suse Leap
« Reply #1 on: November 14, 2018, 02:57:51 pm »
Run your package manager (YaST I don't remember which it is in Suse) and check whether you have installed MySQL or MariaDB. If not, install them.

More info (in the wiki): Databases#The bindings to the database clients
« Last Edit: November 14, 2018, 03:12:56 pm by lucamar »
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus 1.8.4 & 2.0.2 w/FPC 3.0.4 on:
(K|L)Ubuntu 12..16, Windows XP SP3, various DOSes.

nouzi

  • Full Member
  • ***
  • Posts: 106
Re: Newby to Suse Leap
« Reply #2 on: November 14, 2018, 04:07:39 pm »
try this
Code: Bash  [Select]
  1. yum install MariaDB-shared
  2.  
for more info goto
https://mariadb.com/kb/en/library/about-the-mariadb-rpm-files/
my english is  bad
Lazarus 2.0 free pascal 3.0.4
Lazarus trunk  free pascal trunk 
System : windows 7 64bit

eraaijma

  • New member
  • *
  • Posts: 26
Re: Newby to Suse Leap
« Reply #3 on: November 14, 2018, 05:31:58 pm »
Thanks guys, the problem is solved.
With 'software installer' I could see that the library was installed in usr/lib64.
I copied the library to my document directory, job done.

@lucamar: by checking yast, I found what I couldn't find otherwise.
@nouzi: your solution looks straight to the point. I solved it before I could try your idea.

Thanks