Recent

Author Topic: Android API Level 26 requirement?  (Read 2274 times)

cobata

  • New Member
  • *
  • Posts: 49
  • Programmer-analyst
    • COBATA Software - Research, Development, Testing, Consulting
Android API Level 26 requirement?
« on: October 29, 2018, 05:02:00 pm »
Since all Win/ OSX/ Android Store requirements are changed, I would like to ask, if somebody develops for Android Store, what is the case with Lazarus and the new Android API Level 26 requirement, are they met/ supported?
COBATA Software - Research, Development, Testing, Consulting
https://www.COBATA.com/

jmpessoa

  • Hero Member
  • *****
  • Posts: 1787
Re: Android API Level 26 requirement?
« Reply #1 on: October 29, 2018, 06:43:38 pm »

Quote
are they met/ supported?

LAMW? Yes!

But, make sure your Android SDK system contains:

folder "sdk/platforms/android-26"

and

folder  "sdk/build-tools/26.0.2"

Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

cobata

  • New Member
  • *
  • Posts: 49
  • Programmer-analyst
    • COBATA Software - Research, Development, Testing, Consulting
Re: Android API Level 26 requirement?
« Reply #2 on: October 29, 2018, 06:56:27 pm »
Thank you, jmpessoa!
COBATA Software - Research, Development, Testing, Consulting
https://www.COBATA.com/

jmpessoa

  • Hero Member
  • *****
  • Posts: 1787
Re: Android API Level 26 requirement?
« Reply #3 on: October 31, 2018, 06:26:57 pm »

Quote
LAMW? Yes!

But, make sure your Android SDK system contains:

folder "sdk/platforms/android-26"

and

folder  "sdk/build-tools/26.0.2"

Important side note about NDK: for compatibility with old devices [4.x, 5.x] is strongly recommended the use of NDK API < 23
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

 

TinyPortal © 2005-2018