Recent

Author Topic: Richmemo not installing  (Read 3094 times)

dfspannie

  • New member
  • *
  • Posts: 24
Richmemo not installing
« on: September 06, 2018, 10:35:39 am »
Greetings.
when trying to install RichMemo I get the following error :

Compile package richmemopackage 1.0: Exit code 1, Errors: 1, Warnings: 1
wsrichmemo.pas(53,21) Warning: An inherited method is hidden by "class SetHideSelection(const TWinControl;Boolean);"
win32richmemoproc.pas(82,10) Error: Identifier not found "UnicodeEnabledOS"


What to do to resolve the issue ?

Win 10  - tried on 2 different computers one x32, the other x64
Laz 1.8.4
Package was downloaded from a link in the forum.
Thanks

Thaddy

  • Hero Member
  • *****
  • Posts: 8483
Re: Richmemo not installing
« Reply #1 on: September 06, 2018, 10:43:47 am »
Lazarus version? FPC version? Did you try installing it through the online package manager (OPM)?
Read the manuals and if you are a professional get a proper education in computer science. Makes the forum a lot cleaner.

dfspannie

  • New member
  • *
  • Posts: 24
Re: Richmemo not installing
« Reply #2 on: September 06, 2018, 10:51:11 am »
Sorry. FPC 3.0.4 Lazarus version 1.8.4
have not tried OPM.
Did not know about OPM.
Thanks again.

Thaddy

  • Hero Member
  • *****
  • Posts: 8483
Re: Richmemo not installing
« Reply #3 on: September 06, 2018, 10:54:30 am »
Try installing it with OPM and report back. OPM is in the Lazarus menu as the last option in the package menu.
Read the manuals and if you are a professional get a proper education in computer science. Makes the forum a lot cleaner.

dfspannie

  • New member
  • *
  • Posts: 24
Re: Richmemo not installing
« Reply #4 on: September 06, 2018, 11:06:35 am »
Tried the OPM. Same error code.

Thanks.

Thaddy

  • Hero Member
  • *****
  • Posts: 8483
Re: Richmemo not installing
« Reply #5 on: September 06, 2018, 11:10:28 am »
No errors here.... maybe you need to clean up your old install attempt first. Note wp's remark in your other thread.
I tested both.
Read the manuals and if you are a professional get a proper education in computer science. Makes the forum a lot cleaner.

wp

  • Hero Member
  • *****
  • Posts: 5997
Re: Richmemo not installing
« Reply #6 on: September 06, 2018, 11:12:44 am »
Tried the OPM. Same error code.
Really? It compiles fine here when installed via OPM (Win 10, too). The "UnicodeEnabledOS" message is fairly old. Did you mix up versions somehow? Delete the directory which contains you old version which did not work. Go to "Package" > "Package links", find the non-working installation in the list, check it and click "Delete selected". Then go to OPM and try again.

Package was downloaded from a link in the forum.
Packages linked to in the forum are usually snapshots and usually are no longer working after a while. Always try to look if a package is available via OPM - this is the "official" way how packages are distributed for Lazarus now. Of course you may also install directly from the author's git/svn etc repositories or other sources, if you need the most recent version, but then success depends on how well-maintained these packages are. And I would not be surprised to see some trouble if you mix OPM and author's trunk versions occasionally.
« Last Edit: September 06, 2018, 11:21:50 am by wp »
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

Thaddy

  • Hero Member
  • *****
  • Posts: 8483
Re: Richmemo not installing
« Reply #7 on: September 06, 2018, 11:17:28 am »
<you beat me to it>
Read the manuals and if you are a professional get a proper education in computer science. Makes the forum a lot cleaner.

Thaddy

  • Hero Member
  • *****
  • Posts: 8483
Re: Richmemo not installing
« Reply #8 on: September 06, 2018, 11:21:33 am »
In general: use OPM, it is tested and uses current sourcecode. A lot of things you may find elsewhere may be very old and will not compile otherwise.
I commend your efforts to try things, but take some advice and explore the packages available from OPM first.

Otherwise you may run into more trouble than you wish for, although even with OPM you can run into an occasional problem.
Which - of course - you can discuss on this forum.
« Last Edit: September 06, 2018, 11:29:04 am by Thaddy »
Read the manuals and if you are a professional get a proper education in computer science. Makes the forum a lot cleaner.