Recent

Author Topic: Unable to install packages  (Read 800 times)

Raul_ES

  • Full Member
  • ***
  • Posts: 169
  • My interests: Healthcare & Computers
    • My Linkedin Profile, you can add me to stay in contact.
Unable to install packages
« on: February 28, 2020, 09:55:01 pm »
Hi,

After all this time using CodeTyphon I have just discovered that Lazarus is capable of getting packages from online repositories to add new components like barcodes, indy, synapse, etc :D Cool! really cool stuff.

But, I'm having trouble installing certain packages. What I am missing? What should I have read before that I didn't?

I get some errors telling that the manager is unable to find the package (dependency issues) in the repository, unable to compile the dependand package, broken dependency problems, view the package graph.... What I have to do? Where I get the missing packages? *Why* are missing if I am using the official repository?


regards
Pharmacy + Chemistry + Biology + Healthcare + Computing

If you have any interest or project related with these areas feel free to contact me!

GetMem

  • Hero Member
  • *****
  • Posts: 3702
Re: Unable to install packages
« Reply #1 on: February 28, 2020, 10:17:26 pm »
@Raul_ES
Quote
What I am missing? What should I have read before that I didn't?
You did nothing wrong. Some packages are not compatible with your system or Lazarus/FPC version. Other packages are not maintained anymore and won't compile with newer version of Lazarus. As a general rule, you should check the supported widgetset, Laz/FPC versions(see attachment) before install, of course this won't guarantee a successful install, but is a good starting point.
If you find a package that fails, please report it here: https://forum.lazarus.freepascal.org/index.php/topic,34297.0.html or contact the package author and ask for a fix. Packages that are not maintained and cannot be fixed, should be removed in my opinion.

PS: I did try to install Extended packages(the one in your screenshot) and fails here too. I have no idea who is the maintainer and when was added to OPM.
« Last Edit: February 28, 2020, 10:21:16 pm by GetMem »

sstvmaster

  • Full Member
  • ***
  • Posts: 162
Re: Unable to install packages
« Reply #2 on: February 28, 2020, 10:30:27 pm »
I think i found the author, there are also some packages:
https://bitbucket.org/matthieugiroux/extended/downloads/

There is ExtendedPackages.zip with lazextcomponents version 2.2.0.0
Windows 10 (64 bit)
Lazarus: 2.0.8 / Trunk x32

GetMem

  • Hero Member
  • *****
  • Posts: 3702
Re: Unable to install packages
« Reply #3 on: February 29, 2020, 05:58:59 am »
I think i found the author, there are also some packages:
https://bitbucket.org/matthieugiroux/extended/downloads/

There is ExtendedPackages.zip with lazextcomponents version 2.2.0.0
Thanks. I downloaded the package from https://bitbucket.org/matthieugiroux/extended/downloads/ , but it does not work.

Raul_ES

  • Full Member
  • ***
  • Posts: 169
  • My interests: Healthcare & Computers
    • My Linkedin Profile, you can add me to stay in contact.
Re: Unable to install packages
« Reply #4 on: March 05, 2020, 11:16:49 pm »
Thank you,

I see that are a few broken packages with missing dependencies. I was trying to install everything from the official repo but I will have to skip those broken packages. Sad thing is that one of the broken packages was really interesting (System Tools with 1d bar codes, etc). It's wierd but the laz_barcodes package currently only support 2d codes, not 1d.
Pharmacy + Chemistry + Biology + Healthcare + Computing

If you have any interest or project related with these areas feel free to contact me!

 

TinyPortal © 2005-2018