Recent

Author Topic: TListView in report mode - TListItem.ImageIndex not shown?  (Read 1392 times)

MISV

  • Hero Member
  • *****
  • Posts: 633
TListView in report mode - TListItem.ImageIndex not shown?
« on: August 20, 2018, 01:46:11 pm »
Can anyone confirm their TListView (in report mode) is not showing images for items? (Works in Carbon)

wp

  • Hero Member
  • *****
  • Posts: 6362
Re: TListView in report mode - TListItem.ImageIndex not shown?
« Reply #1 on: August 20, 2018, 03:03:41 pm »
Did you assign the ImageList to the SmallImages of the ListView? I should work. Otherwise you should post a demo.
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

MISV

  • Hero Member
  • *****
  • Posts: 633
Re: TListView in report mode - TListItem.ImageIndex not shown?
« Reply #2 on: August 20, 2018, 10:26:25 pm »
Yes, SmallImages assigned and ViewStyle set to vsReport

Same DFM/code works in Lazarus/Carbon and Delphi/Windows (have not checked other at present)


skalogryz

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2284
    • havefunsoft.com
Re: TListView in report mode - TListItem.ImageIndex not shown?
« Reply #3 on: August 20, 2018, 10:28:54 pm »
check out point 1 at #33127
« Last Edit: August 20, 2018, 10:42:37 pm by skalogryz »
Patron Cocoa Widgetset development https://www.patreon.com/skalogryz

MISV

  • Hero Member
  • *****
  • Posts: 633
Re: TListView in report mode - TListItem.ImageIndex not shown?
« Reply #4 on: August 20, 2018, 10:43:56 pm »
Great - already reported! :)

I did also notice another problem with columns ordering - weird issue with all columns *content* moved one column to left. (Guess: Maybe because I had a column without any data at all...)

- I will investigate that further soon (only happens on Cocoa, but do not spend time on this - I will make a proper bug report later if the problem persist)
« Last Edit: August 21, 2018, 12:32:17 am by MISV »

VTwin

  • Hero Member
  • *****
  • Posts: 787
  • Former Turbo Pascal 3 user
Re: TListView in report mode - TListItem.ImageIndex not shown?
« Reply #5 on: August 20, 2018, 11:39:13 pm »
I reported that ImageLists were not working in menus:

https://bugs.freepascal.org/view.php?id=33736

and was told it was (EDIT not resolved) a duplicate. However it still does not seem to be working. I have popup menus with images that work on all other platforms. Related?

« Last Edit: August 20, 2018, 11:43:38 pm by VTwin »
“Talk is cheap. Show me the code.” -Linus Torvalds

macOS 10.13.6: Lazarus 2.0 (2.0.7) fixes svn 62148 (64 bit Cocoa)
Ubuntu 18.04.3: Lazarus 2.0.6 (64 bit on VBox)
Windows 7 Pro SP1: Lazarus 2.0.6 (64 bit on VBox)
fpc 3.0.4