Recent

Author Topic: FPC 3.2.x series branched, trunk update to 3.3.1  (Read 66334 times)

wp

  • Hero Member
  • *****
  • Posts: 7539
Re: FPC 3.2.x series branched, trunk update to 3.3.1
« Reply #75 on: January 15, 2019, 11:56:17 pm »
Something must be badly wrong with this list. I quickly tested some of the packages that I know, CalLite,  Industrial, ColorPalette, LazBarCode, mbColorLib - and they all compile fine. Which IDE and which FPC are used? I used Laz trunk / fpc 3.0.4 / 32 bit on Win10 / 64 bit.

Why are fpvectorial and lazopenglcontext in the list? They is contained in the standard Lazarus distribution.
« Last Edit: January 16, 2019, 12:01:05 am by wp »
Mainly Lazarus trunk / fpc 3.2.0 / all 32-bit on Win-10, but many more...

valdir.marcos

  • Hero Member
  • *****
  • Posts: 993
Re: FPC 3.2.x series branched, trunk update to 3.3.1
« Reply #76 on: January 16, 2019, 12:44:12 am »
I think I confused these fpcupdeluxe modules with OPM, sorry.
You're welcome.

Quote
Where do these modules come from?
Please, see the attached image.

Quote
How are they updated?
I don't know.

Quote
Why does fpcupdeluxe distribute its own packages when there is now OPM which is even integrated in the IDE?
I don't know.

As a matter of fact, I had never used FPCUPdeluxe before this week.
I got to it because of the difficult to build fpc on command line.
I am testing all its features to learn how it works.
It's an excellent tool.
As OPM was not compiling in the last days, FPCUPdeluxe proved to be a great alternative.

valdir.marcos

  • Hero Member
  • *****
  • Posts: 993
Re: FPC 3.2.x series branched, trunk update to 3.3.1
« Reply #77 on: January 16, 2019, 12:49:52 am »
Code: Pascal  [Select][+][-]
  1. * bgragames (the modules bgrabitmap, bgracontrols and bgracontrolsfx were previously properly installed)
About BGRAGames not compiling, is an outdated package, I should check if I can fix it, but for making a game better use Castle Game Engine that is cross platform and works for mobile devices.
I don't intend to build games. I was just trying to install all available modules for testing purposes.

Quote
Edit: I see LazPaint in the list, is not a package that can be installed, is a regular lazarus project. In the past that repo included bgrabitmap, but now they are in 2 separate repos.
I didn't know.
Thanks.

valdir.marcos

  • Hero Member
  • *****
  • Posts: 993
Re: FPC 3.2.x series branched, trunk update to 3.3.1
« Reply #78 on: January 16, 2019, 12:57:03 am »
Something must be badly wrong with this list. I quickly tested some of the packages that I know, CalLite,  Industrial, ColorPalette, LazBarCode, mbColorLib - and they all compile fine.
Which IDE and which FPC are used? I used Laz trunk / fpc 3.0.4 / 32 bit on Win10 / 64 bit.
I am using FPCUPdeluxe to test Lazarus 2.0 RC 3 + fixes_2_0 and FPC 3.2 beta + fixes_3_2.

Quote
Why are fpvectorial and lazopenglcontext in the list? They is contained in the standard Lazarus distribution.
I don't know.

valdir.marcos

  • Hero Member
  • *****
  • Posts: 993
Re: FPC 3.2.x series branched, trunk update to 3.3.1
« Reply #79 on: January 16, 2019, 01:06:52 am »
I think I confused these fpcupdeluxe modules with OPM, sorry.
Why does fpcupdeluxe distribute its own packages when there is now OPM which is even integrated in the IDE?
As soon as OPM got back compiling, I will test on Lazarus 2.0 RC 3 + fixes_2_0 and FPC 3.2 beta + fixes_3_2 the packages I should really use.
My problem is that building, testing and debuging FPC is not as easy as Lazarus and I need that to better help the community.

wp

  • Hero Member
  • *****
  • Posts: 7539
Re: FPC 3.2.x series branched, trunk update to 3.3.1
« Reply #80 on: January 16, 2019, 01:27:25 am »
I am using FPCUPdeluxe to test Lazarus 2.0 RC 3 + fixes_2_0 and FPC 3.2 beta + fixes_3_2.
You are not mentioning the bitness of your OS, but further up I get the impression that it is 32 bit. In this case, the number of packages that you want to install are way too much and you will run out of memory - there are some threads about this here in the forum. I don't know what fpcupdeluxe will tell you in this case.
Mainly Lazarus trunk / fpc 3.2.0 / all 32-bit on Win-10, but many more...

valdir.marcos

  • Hero Member
  • *****
  • Posts: 993
Re: FPC 3.2.x series branched, trunk update to 3.3.1
« Reply #81 on: January 16, 2019, 01:48:02 am »
I am using FPCUPdeluxe to test Lazarus 2.0 RC 3 + fixes_2_0 and FPC 3.2 beta + fixes_3_2.
You are not mentioning the bitness of your OS, but further up I get the impression that it is 32 bit.
Correct, I am testing Lazarus 32bit.

Quote
In this case, the number of packages that you want to install are way too much and you will run out of memory - there are some threads about this here in the forum.
I didn't know that, yet.

Quote
I don't know what fpcupdeluxe will tell you in this case.
Neither do I.  :)

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1330
Re: FPC 3.2.x series branched, trunk update to 3.3.1
« Reply #82 on: January 16, 2019, 04:38:00 am »
Fpcupdeluxe gets all of its modules/packages from the original online sources. So, for the success of installing them, its fully dependent on the maintainers of these sources.

af0815

  • Hero Member
  • *****
  • Posts: 582
Re: FPC 3.2.x series branched, trunk update to 3.3.1
« Reply #83 on: January 16, 2019, 06:22:12 am »
FPC Fixes 3.2 include the patch on win32 with setpeflag $20. So you can build a bigger IDE.FPC 3.0x have the issue IMHO. I think people with the next stable 3.0.4 and 2.0 will complain more and more  8-)

« Last Edit: January 16, 2019, 06:25:16 am by af0815 »
regards
Andreas

valdir.marcos

  • Hero Member
  • *****
  • Posts: 993
Re: FPC 3.2.x series branched, trunk update to 3.3.1
« Reply #84 on: January 16, 2019, 07:01:08 am »
I am using FPCUPdeluxe to test Lazarus 2.0 RC 3 + fixes_2_0 and FPC 3.2 beta + fixes_3_2. Everything is 32bit.

When I install any or all of the packages lclfpreport.lpk, lazfpreportdesign.lpk, lazidefpreport.lpk from "C:\fpcupdeluxe\lazarus\components\fpreport\" and "C:\fpcupdeluxe\lazarus\components\fpreport\design\",  Lazarus gets broken during rebuild and doesn't work anymore.

Should I open a bug report?
« Last Edit: January 16, 2019, 07:33:35 am by valdir.marcos »

af0815

  • Hero Member
  • *****
  • Posts: 582
Re: FPC 3.2.x series branched, trunk update to 3.3.1
« Reply #85 on: January 16, 2019, 07:29:33 am »
Should I open a bug report?
Do you know, is it comming from FPC 3.2 or a Lazarus 2.0 Problem ?! Look if this is eventually fixed on trunk. So you can make a request for backporting.
regards
Andreas

valdir.marcos

  • Hero Member
  • *****
  • Posts: 993
Re: FPC 3.2.x series branched, trunk update to 3.3.1
« Reply #86 on: January 16, 2019, 07:36:38 am »
Should I open a bug report?
Do you know, is it comming from FPC 3.2 or a Lazarus 2.0 Problem ?! Look if this is eventually fixed on trunk. So you can make a request for backporting.
fpReport is a new package for future FPC 3.2.0. I am trying to test it.

af0815

  • Hero Member
  • *****
  • Posts: 582
Re: FPC 3.2.x series branched, trunk update to 3.3.1
« Reply #87 on: January 16, 2019, 08:22:12 am »
No Problem to compile and install fpreport. BUT Lazarus wont start. On commandline no message, but if i activate --debug-log=log.txt on the commandline i see

Quote
using config file D:\data\lazdev\work\lazarus\lazarus.cfg
[FORMS.PP] ExceptionOccurred
  Sender=EInOutError
  Exception=Can not load Freetype library "freetype-6.dll". Check your installation.
  Stack trace:
  $00E70209
  $00E7028D
  $00E7030A
There is a dll missing.

Edit: You have to install freetype-6.dll AND zlib1.dll !!! for your bitness eg. 32bit for a 32Bit Lazarus.
« Last Edit: January 16, 2019, 08:27:59 am by af0815 »
regards
Andreas

JD

  • Hero Member
  • *****
  • Posts: 1793
Re: FPC 3.2.x series branched, trunk update to 3.3.1
« Reply #88 on: January 16, 2019, 08:59:04 am »
Should I open a bug report?
Do you know, is it comming from FPC 3.2 or a Lazarus 2.0 Problem ?! Look if this is eventually fixed on trunk. So you can make a request for backporting.
fpReport is a new package for future FPC 3.2.0. I am trying to test it.

I have the same problem with ftpReport. I've been unable to install the GUI component because it breaks the Lazarus IDE.

JD
Windows (10, 7) - Lazarus 2.1/FPC 3.2, Delphi

Indy 10.6 series; mORMot; Zeos 7.3; SQLite, Firebird, PostgreSQL & MariaDB; VirtualTreeView 5.5.3 R1

af0815

  • Hero Member
  • *****
  • Posts: 582
Re: FPC 3.2.x series branched, trunk update to 3.3.1
« Reply #89 on: January 16, 2019, 10:18:36 am »
By me, nothing is broken. Actual (2 hours ago) fpc fixes 3.2 and actual lazarus fixes 2.0 compiles on win10/64 plattform win32. With fpcupdeluxe.only dll was missing.

What is your trouble. Everybody says it is broken, but i see no log or any message.
« Last Edit: January 16, 2019, 10:20:39 am by af0815 »
regards
Andreas

 

TinyPortal © 2005-2018