Recent

Author Topic: Lazarus cocoa make problem  (Read 7374 times)

xinyiman

  • Hero Member
  • *****
  • Posts: 1969
    • Lazarus and Free Pascal italian community
Lazarus cocoa make problem
« on: August 17, 2018, 06:22:44 pm »
Hi guys, I have a problem installing lazarus cocoa. I downloaded fpc and lazarus trunk version with fpcupdeluxe. Then in the lazaru folder I launched the make LCL_PLATFORM = cocoa command and I get the following error:

Code: Pascal  [Select]
  1. (9001) Assembling (pipe) ../units/i386-darwin/cocoa/customformeditor.s
  2. (3104) Compiling /Users/ngit/lazarus/lazarus_cocoa_2018_08_17/lazarus/designer/askcompnamedlg.pas
  3. /Users/ngit/lazarus/lazarus_cocoa_2018_08_17/lazarus/designer/askcompnamedlg.pas(95,46) Error: (4025) Incompatible type for arg no. 2: Got "PPropInfo", expected "AnsiString"
  4. Hint: (5039) Found declaration: GetPropValue(TObject;const AnsiString;Boolean):Variant;
  5. /Users/ngit/lazarus/lazarus_cocoa_2018_08_17/lazarus/designer/askcompnamedlg.pas(135,37) Error: (4025) Incompatible type for arg no. 2: Got "PPropInfo", expected "AnsiString"
  6. Hint: (5039) Found declaration: SetPropValue(TObject;const AnsiString;const Variant);
  7. askcompnamedlg.pas(307) Fatal: (10026) There were 2 errors compiling module, stopping
  8. Fatal: (1018) Compilation aborted
  9. make[2]: *** [lazarus] Error 1
  10. make[1]: *** [ide] Error 2
  11. make: *** [ide] Error 2
  12.  

Yesterday I did the same procedure on another mac and it worked.
Win10, Ubuntu and Mac
Lazarus: 2.1.0
FPC: 3.3.1

skalogryz

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2283
    • havefunsoft.com
Re: Lazarus cocoa make problem
« Reply #1 on: August 17, 2018, 07:49:52 pm »
what's fpc version you're building with?
Patron Cocoa Widgetset development https://www.patreon.com/skalogryz

xinyiman

  • Hero Member
  • *****
  • Posts: 1969
    • Lazarus and Free Pascal italian community
Re: Lazarus cocoa make problem
« Reply #2 on: August 18, 2018, 09:37:49 am »
Trunk version
Win10, Ubuntu and Mac
Lazarus: 2.1.0
FPC: 3.3.1

xinyiman

  • Hero Member
  • *****
  • Posts: 1969
    • Lazarus and Free Pascal italian community
Re: Lazarus cocoa make problem
« Reply #3 on: August 22, 2018, 11:59:43 am »
I start thinking that for some it does not compile with the right version of the fpc. I have other versions of lazarus on my Mac, an older version 1.6 installed by the official installer, then a 1.8 lazarus version (3.0.4 of pfc) installed with fpcupdeluxe. And now I installed the trunk version of both lazarus and fpc always with fpcupdeluxe. But when I send the command:

make LCL_PLATFORM = cocoa

The problem happens. I can tell make to install with a specific version of fpc parameterizing it type

make LCL_PLATFORM = cocoa fpc_dir = / Users / helloworld / fpc /

Something like that, so make sure you have compiled with the last downloaded fpc. Thank you
Win10, Ubuntu and Mac
Lazarus: 2.1.0
FPC: 3.3.1