Recent

Author Topic: Can't install ZeosLib / LazActiveX  (Read 4730 times)

wp

  • Hero Member
  • *****
  • Posts: 7529
Re: Can't install ZeosLib / LazActiveX
« Reply #15 on: July 13, 2018, 11:26:46 pm »
Open package zdbc.lpk ("Package" > "Open package file"), and remove the unit "ZDbcAdo.pas", this unit uses ActiveX and makes the package non-crossplatform. Afterwards you cannot use Microsofts ADO any more to work with Access databases.

I did not check the other units in this package, maybe there are other ones using ActiveX or similiar Windows-only units.
« Last Edit: July 13, 2018, 11:29:31 pm by wp »
Mainly Lazarus trunk / fpc 3.2.0 / all 32-bit on Win-10, but many more...

Phil

  • Hero Member
  • *****
  • Posts: 2750
Re: Can't install ZeosLib / LazActiveX
« Reply #16 on: July 13, 2018, 11:29:06 pm »
Open package zdbc.lpk ("Package" > "Open package file"), and remove the unit "ZDbcAdo.pas", this unit uses ActiveX and makes the package non-crossplatform. Afterwards you cannot use Microsofts ADO any more to work with Access databases.

With 7.2.4 stable, ZDbcAdo.pas is a no-op that does not use ActiveX unless ENABLE_ADO is defined.


Trenatos

  • Hero Member
  • *****
  • Posts: 524
    • MarcusFernstrom.com
Re: Can't install ZeosLib / LazActiveX
« Reply #17 on: July 14, 2018, 01:17:05 am »
Phil, yeah could be a mixup due to multiple attempts, will try on Monday on that machine again

af0815

  • Hero Member
  • *****
  • Posts: 582
Re: Can't install ZeosLib / LazActiveX
« Reply #18 on: July 14, 2018, 09:11:37 am »
Maybe on OS-X ADO is enabled by accident. Eventually the OS detection and defines goes wrong. I use trunk of ZEOS because trunk is for me more stable than the stable packages. But i have to work with MS-SQL Server Connection under Win, Linux and Rasbian. For me is ADO disabled by default on all plattforms.
regards
Andreas

dogriz

  • Full Member
  • ***
  • Posts: 108
    • Tech blog - Delphi, Lazarus, Firebird, Windows, Linux, Android...
Re: Can't install ZeosLib / LazActiveX
« Reply #19 on: July 16, 2018, 07:52:54 am »
The same problem with ZEOS trunk is on Linux, too.
Since I don't use ADO, I'll try to remove "ZDbcAdo.pas"...
FPC 3.0.4
Lazarus 2.0.6
Debian x86_64, arm

af0815

  • Hero Member
  • *****
  • Posts: 582
Re: Can't install ZeosLib / LazActiveX
« Reply #20 on: July 16, 2018, 09:03:46 am »
I leave a message in the ZEOS Forum


Edit:
ENABLE_OLEDB is IMHO activated by accidence. It should not activated - see ZEOS.onc line 408.

Remove or disable the Line 58 $DEFINE ENABLE_OLEDB  in ZDbcOleDB.pas and Zeos will compile in Linux.

 
« Last Edit: July 16, 2018, 09:12:34 am by af0815 »
regards
Andreas

miab3

  • Full Member
  • ***
  • Posts: 108
Re: Can't install ZeosLib / LazActiveX
« Reply #21 on: July 16, 2018, 11:04:57 am »
Code: Pascal  [Select][+][-]
  1. // Enables ADO support in TZConnection/TZDataset
  2. {$IF not defined(ZEOS_DISABLE_ADO) and defined(MSWINDOWS)}
  3.   {$DEFINE ENABLE_ADO}
  4. {$IFEND}
  5. ...
  6. // Enables OleDB support in TZConnection/TZDataset
  7. {$IF not defined(ZEOS_DISABLE_OLEDB) and defined(MSWINDOWS)}
  8.   {$DEFINE ENABLE_OLEDB}
  9. {$IFEND}

in zeos.inc should exclude from compilation in Linux ADO and OLEDB.

Indeed in ZDbcOleDB.pas there is an error, it should be:
{.$DEFINE ENABLE_OLEDB}

This of course applies to ZEOS 7.3.x in 7.2.x should not be ZDbcOleDB.pas file:
ZEOS 7.2.4(p) - current version with the current patches.
https://sourceforge.net/p/zeoslib/code-0/HEAD/tree/branches/7.2-patches/

ZEOS 7.3.x - development version (with added OLEDB for Win and ODBC).
http://sourceforge.net/p/zeoslib/code-0/HEAD/tree/branches/testing-7.3/

Michal
« Last Edit: July 16, 2018, 11:22:42 pm by miab3 »

 

TinyPortal © 2005-2018