Recent

Author Topic: Can't install ZeosLib / LazActiveX  (Read 4735 times)

Trenatos

  • Hero Member
  • *****
  • Posts: 524
    • MarcusFernstrom.com
Can't install ZeosLib / LazActiveX
« on: July 13, 2018, 03:25:44 pm »
I'm trying to install ZeosLib, but it's complaining about not having ActiveX.

So I try to install the LazActiveX package, and it fails to rebuild with "Cannot find Windows used by activexcontainer of package LazActiveX".

Trunk FPC and Lazarus.

Looking around but not really seeing much about this.

Phil

  • Hero Member
  • *****
  • Posts: 2750
Re: Can't install ZeosLib / LazActiveX
« Reply #1 on: July 13, 2018, 03:26:54 pm »
I'm trying to install ZeosLib, but it's complaining about not having ActiveX.

So I try to install the LazActiveX package, and it fails to rebuild with "Cannot find Windows used by activexcontainer of package LazActiveX".

Trunk FPC and Lazarus.

Looking around but not really seeing much about this.

Have to ask: you are on Windows, right?

Trenatos

  • Hero Member
  • *****
  • Posts: 524
    • MarcusFernstrom.com
Re: Can't install ZeosLib / LazActiveX
« Reply #2 on: July 13, 2018, 03:28:43 pm »
No I'm on OS X.

ZeosLib is Windows-only?

Thaddy

  • Hero Member
  • *****
  • Posts: 10451
Re: Can't install ZeosLib / LazActiveX
« Reply #3 on: July 13, 2018, 03:39:36 pm »
ActiveX is windows only. I stopped using zeos (personal taste) , just use sqldb: more stable and just as versatile.
When you ask a question that is actually answered in the documentation, you are either lazy or a moron.

Trenatos

  • Hero Member
  • *****
  • Posts: 524
    • MarcusFernstrom.com
Re: Can't install ZeosLib / LazActiveX
« Reply #4 on: July 13, 2018, 03:41:54 pm »
I wanted to give Zeos a shot, I've heard good things.

I know ActiveX is Windows-only, but for some reason Zeos won't compile without it, so I was hoping I could install it without it getting in the way.

Guess not.

In the end, I just need to get a few MySQL and MSSQL connections going, should be fine with sqldb.

Thaddy

  • Hero Member
  • *****
  • Posts: 10451
Re: Can't install ZeosLib / LazActiveX
« Reply #5 on: July 13, 2018, 04:03:18 pm »
It will work cross-platform, though. I wonder why it needs activeX on windows? You need another answer. I just wrote what I did and that may not be complete.
When you ask a question that is actually answered in the documentation, you are either lazy or a moron.

Trenatos

  • Hero Member
  • *****
  • Posts: 524
    • MarcusFernstrom.com
Re: Can't install ZeosLib / LazActiveX
« Reply #6 on: July 13, 2018, 06:13:51 pm »
Not sure, I'll report it but for now sqldb works fine for what I need.

af0815

  • Hero Member
  • *****
  • Posts: 582
Re: Can't install ZeosLib / LazActiveX
« Reply #7 on: July 13, 2018, 09:23:34 pm »
Zeos is win and Linux. No and never need for ActiveX.
regards
Andreas

Phil

  • Hero Member
  • *****
  • Posts: 2750
Re: Can't install ZeosLib / LazActiveX
« Reply #8 on: July 13, 2018, 09:47:41 pm »
Zeos is win and Linux. No and never need for ActiveX.

Looks to me like if you define ENABLE_ADO it _will_ use ActiveX, although this is undefined by default in my ZDbcAdo.pas. He should also check whether ENABLE_ADO is defined somewhere else if not defined in ZDbcAdo.pas.

Trenatos: where did you download ZeosLib from. I look at source of version 7.2.4 stable from SourceForge.

https://sourceforge.net/projects/zeoslib/

Trenatos

  • Hero Member
  • *****
  • Posts: 524
    • MarcusFernstrom.com
Re: Can't install ZeosLib / LazActiveX
« Reply #9 on: July 13, 2018, 10:05:38 pm »
I tried both fpcupdeluxe and sourceforge (zeosdbo-7.2.4-stable.zip)

Phil

  • Hero Member
  • *****
  • Posts: 2750
Re: Can't install ZeosLib / LazActiveX
« Reply #10 on: July 13, 2018, 10:09:32 pm »
I tried both fpcupdeluxe and sourceforge (zeosdbo-7.2.4-stable.zip)

You haven't provided much info about the error. What unit is the ActiveX error occurring?

Trenatos

  • Hero Member
  • *****
  • Posts: 524
    • MarcusFernstrom.com
Re: Can't install ZeosLib / LazActiveX
« Reply #11 on: July 13, 2018, 10:49:23 pm »
Full instructions to reproduce:

Download the zeosdbo-7.2.4-stable zip file.

Open packages/lazarus/zcomponent.lpk as per README.txt

Click Compile

Watch immediate breakdown: ZDbcOleDB.pas(61,55) Fatal: Cannot find ActiveX used by ZDbcOleDB of package zdbc.

System: OS X El Capitan - 10.11.5
Trunk FPC and Laz as per a couple of days ago.
« Last Edit: July 13, 2018, 10:52:00 pm by Trenatos »

Phil

  • Hero Member
  • *****
  • Posts: 2750
Re: Can't install ZeosLib / LazActiveX
« Reply #12 on: July 13, 2018, 11:03:19 pm »
Watch immediate breakdown: ZDbcOleDB.pas(61,55) Fatal: Cannot find ActiveX used by ZDbcOleDB of package zdbc.

I don't see file ZDbfOleDB.pas in the 7.2.4 stable zip.

Trenatos

  • Hero Member
  • *****
  • Posts: 524
    • MarcusFernstrom.com
Re: Can't install ZeosLib / LazActiveX
« Reply #13 on: July 13, 2018, 11:17:48 pm »
Looks like it's from zdbc, which is required by zcomponent

Phil

  • Hero Member
  • *****
  • Posts: 2750
Re: Can't install ZeosLib / LazActiveX
« Reply #14 on: July 13, 2018, 11:22:15 pm »
Looks like it's from zdbc, which is required by zcomponent

Your zdbc package says 7.3. The one included with 7.2.4 stable should say 7.2, I believe. You're probably mixing up packages from multiple distributions. Maybe an fpcupdeluxe mixup?


 

TinyPortal © 2005-2018