Recent

Author Topic: MySQL 8 and Lazarus  (Read 9543 times)

MrSlay

  • Newbie
  • Posts: 1
MySQL 8 and Lazarus
« on: July 12, 2018, 05:45:54 am »
Forgive my ignorance, as I am somewhat a beginner at this.  I have recently been ask to program a database software.  I have decided to go with lazarus, and mysql for my software.  problem is there is only a data component for mysql 5.0 thru 5.7.  and I am running mysql server 8.  is there a package update out there somewhere that I havent come across yet that incorporates mysql 8?

GAN

  • Sr. Member
  • ****
  • Posts: 354
Re: MySQL 8 and Lazarus
« Reply #1 on: July 12, 2018, 06:31:32 am »
You can use the package ZeosLib https://sourceforge.net/projects/zeoslib/
Lazarus 2.0.8 FPC 3.0.4 Linux Mint Mate 19.3
Zeos 7̶.̶2̶.̶6̶ 7.1.3a-stable - Sqlite 3.32.3 - LazReport

Mlhy

  • Newbie
  • Posts: 1
Re: MySQL 8 and Lazarus
« Reply #2 on: April 11, 2019, 09:24:57 am »
This solution works for me: I have installed Lazarus v2.0 and MySQL server 8.0. For connection to MySQL server I use MySQL57Connection component and library libmySQL.dll v 5.7 (taken from the MySQL server 5.7 installation).


diego bertotti

  • Full Member
  • ***
  • Posts: 101
Re: MySQL 8 and Lazarus
« Reply #3 on: March 31, 2022, 01:40:56 pm »
Hello.

I had the same problem.

I was finally able to fix it, by copying libmysql.dll from the mysql lib folder. In my case, "D:\mysql57\lib", and you need to pay attention to binary versions. OS, .exe and dll must be all 64 or all 32 bit.

I used component 5.7, with dll version 5.7, but my mysql installation is version 8, (xampp) and it's working!

Hemptwister

  • Newbie
  • Posts: 2
Re: MySQL 8 and Lazarus
« Reply #4 on: January 31, 2023, 07:28:47 pm »
I just installed Lazarus on Windows and it has a MYSQL80 connector. Is it Windows only? My Linux version only goes up to 57.

PascalDragon

  • Hero Member
  • *****
  • Posts: 4957
  • Compiler Developer
Re: MySQL 8 and Lazarus
« Reply #5 on: January 31, 2023, 08:59:42 pm »
I just installed Lazarus on Windows and it has a MYSQL80 connector. Is it Windows only? My Linux version only goes up to 57.

What is the version of your Lazarus/FPC?

eldonfsr

  • Sr. Member
  • ****
  • Posts: 360
Re: MySQL 8 and Lazarus
« Reply #6 on: February 01, 2023, 02:23:12 am »
Yes is possible to work with mysql8 and connecting to lazarus using 5.7 connector i suggest you use loadlibrary and put dll on your folder where  is running your app, this way for me aboid a lot problems with erro can load library...

just something like this...

   SQLDLL.LibraryName:=WideString(ExtractFilePath(ParamStr(0)) + 'libmysql.dll');
    SQLDLL.LoadLibrary;   
 for windows i don't know on linux.... i don't have a machine running linux...

 

 

TinyPortal © 2005-2018