Recent

Author Topic: lclextensions 0.61 can no longer compile with cocoa-trunk  (Read 1416 times)

MISV

  • Hero Member
  • *****
  • Posts: 633
lclextensions 0.61 can no longer compile with cocoa-trunk
« on: July 10, 2018, 12:22:41 am »
I am working on getting my software working on Lazarus Darwin/64bit/Cocoa buildss

When installing lclextensions using fpcupdeluxe it tries to install 0.5.1

However when installing virtualtreeviewnew (5.x) using fpcdeluxe it tries to install lclextensions 0.6.1

But... lclextensions installation is error because it can not find "uses.inc" ... this is a new problem AFAIK

For my needs I need to use virtualreeviewnew, so I need to get lclextensions 0.6.1 installed properly

...

my old manual lclextensions from before fpcupdeluxe also does not work
« Last Edit: July 10, 2018, 12:31:45 am by MISV »

MISV

  • Hero Member
  • *****
  • Posts: 633
Re: lclextensions 0.61 can no longer compile with cocoa-trunk
« Reply #1 on: July 10, 2018, 09:14:32 am »
Note: Problem persist - even with 100% fresh trunk followed by selecting to install module virtualtreeviewnew

I also get the same problem if I try to install lclextensions 0.6.1 myself, so this may not be a fpcupdeluxe problem - but probably a cocoa widget trunk update problem with missing uses.inc file maybe?

But before reporting - could anyone else trying "trunking" cocoa and replicate?
« Last Edit: July 10, 2018, 01:28:39 pm by MISV »

MISV

  • Hero Member
  • *****
  • Posts: 633