Forum > Database

Using dbexport

<< < (5/5)

Dear ALL,

Installation of FPC/Lazarus in Linux should be as easy as it is in Windows. And that is where Debian packages come to the rescue of (Debian-based) Linux users.

So, I have finally solved the problem, in the most simple and direct way: as suggested by user @del here (,38728.0.html) I downloaded the Debian packages of a more recent version of FPC/Lazarus from the official SourceForge repository and installed them directly. Now the previous prpblem with 'missing packages' disappeared and I can install any component without any further problems.

It turned out that the whole problem was the version of FPC/Lazarus (1.8.2) available in the repository of my Linux Mint distribution and not (necessarily) the distro repository itself. It remains a mystery why it has worked well until I attempted to install the dbexport package, but this is immaterial now.

I suppose I owe an apology to user @af0815, and here it is. Sorry, man. (But I still have myself no need to user more than the Windows and the Linux Debian installation packages for getting FPC/Lazarus up and running).

With best wishes

Sometimes I am getting trouble to build IDE from inside of the IDE then i change to Terminal/Console and type:
>make clean
>make bigide

it helps,the problems are solved but your components and not included. Now you must build it from inside of the IDE again.


[0] Message Index

[*] Previous page

Go to full version