Author Topic: Installs on Linux Mint - won't rebuild  (Read 2891 times)


  • Newbie
  • Posts: 4
Installs on Linux Mint - won't rebuild
« on: June 23, 2018, 10:02:03 am »
Installing Laz 1.8.2 on Linux Mint 18.4 will install and compile a "hello world" sample project.  Great!

But now I want to add OPM package (or even just do a Rebuild) and it errors.

I've tried extensive copying of purported missing "LazControlDsgn.compiled" and it's other 5 files. - moving them from .../install/gtk to .../design/gtk.

Upon getting these files, I get the - "there are 2 instances of the .ppu file....."

Abandoning this, I just try and rebuild and it errors with "can't open file .../lazarus.o

After spending hours trying to pursue every known thread, I would just like to install a package and have it rebuild.

I have not been able to see any instructions about where the paths should be --- most posts say that it should not have to be done because fp is so good at setting these..... How about a definitive example of a install that will rebuild Laz??

I suspect that whoever rebuild the dist omitted the declared pathway of the "LazControlDsgn.compiled" group.  It should not be that hard to trick the declarations of the paths so that it will pick up the compiled, installed package and not confuse the rebuild as to where it should run and save the proper pathways.

Please help.  I was able to get the new version 1.8.4 working fine with OPM in windows and my launch depends on having the Linux Environment.

Kindest Regards to the group...


  • Hero Member
  • *****
  • Posts: 538
Re: Installs on Linux Mint - won't rebuild
« Reply #1 on: June 23, 2018, 10:13:58 am »
did you install as per steps in:  ?
(only Lazarus part)
Lazarus 2.0.2 64b on Debian LXDE 10


  • Hero Member
  • *****
  • Posts: 4017
  • My goal: build my own game engine using Lazarus
Re: Installs on Linux Mint - won't rebuild
« Reply #2 on: June 23, 2018, 10:18:53 am »
Installing Laz 1.8.2 on Linux Mint 18.4 ...

I just checked the web, there are Linux Mint 18.3 and 19 but I can't find 18.4.

Have you tried Lazarus 1.8.4? Linux Mint is a fork of Ubuntu, maybe this link can help you:,41524.0.html


  • Newbie
  • Posts: 4
Re: Installs on Linux Mint - won't rebuild
« Reply #3 on: June 23, 2018, 07:36:52 pm »
My apologies for the jumbled specifics on the post.  It was at the end of a long frustrating week.

Thank you for your replies tudi_x and Handoko.

I have tried every possibility suggested from numerous posts.  I had hoped not to get directed into this version or that version because that is not the actual fault of the problem that I am having.

I would like to know (outside of FP, Linux Mint) - Where the directories are set in every Lazarus install, and where they look (the proper folders that they look for in an install) - you know, looking for the .pp files, when they rebuild??

The real problem in my attempt to install stems from the person that put together the particular "build".  I'm not blaming them because I know that the program itself was designed to "automatically" install.  (this is great and also much appreciated).

My best guess is that when they did the build, they had all of the proper "pointers" in the build installed with each of the included components, but "LazControlDsgn.compiled" and it's attending files were somehow not pointed to correctly in the saved snapshot that became the "map" of the build - or what would be invoked during a "rebuild" when a new component would be installed.

I had hoped that a build "configuration" type file could be modified to point to the correct pathway that the Laz uses as the map of the rebuild or how the "option pathway" is defined.

To clear up the vagueness of my first post, I have a product ready in Windows to move to Linux and have spent numerous hours trying to use - Centos 7, Linux Mint for the working version of Kernal 4.15.0-23-generic x86_64, bits: 64, Desktop: Cinnamon 3.8.4, Distro: Linux Mint 19 Tara.  The Lazarus that is Version #: 1.8.2+dfsg-3. is what I am trying to load ( I have to use a different one for Raspberry PI but that is for another day.

I know that I could cross compile the product and make it run via the windows compile for another platform but that will not prove the compatibility of the components and is not a long term solution to the approach that is needed for the product.

With the way that Linux watches and keeps you up to date, and the adoption of OPM, I think that it is advantageous that you use the most up-to-date current version of the available product. I'm sure that I can't tell you how great the OPM is and how many hours of searching, testing and frustration that go with using third party solutions ( there are alot of very good talented users that are making great components in the community).

I am very appreciative of the community.  I have used the forums for years and seldom post because most of my questions are answered by everyone here.  I only mention this because my member description describes me a "Newbie".  I have been in the industry since using a DEC PDP/8e.

Thanks again for your assistance. 


  • Sr. Member
  • ****
  • Posts: 366
Re: Installs on Linux Mint - won't rebuild
« Reply #4 on: June 23, 2018, 11:57:40 pm »
I believe Mint is a Debian derivative? Why don't you use latest .debs from Sourceforge?
Never liked Debian stock packages, because they are lagging versions and weirdly structured.
Lazarus 2.0.10 FPC 3.2.0 x86_64-linux-gtk2 @ Ubuntu 20.04 XFCE


TinyPortal © 2005-2018