Recent

Author Topic: Error installing BGRA Bitmap and BGRA Controls packages  (Read 1317 times)

mmmmm

  • Newbie
  • Posts: 2
Error installing BGRA Bitmap and BGRA Controls packages
« on: January 27, 2019, 01:36:17 pm »
Hello, I recently reported an issue with installing the packages BGRA Bitmap and BGRA Controls in the Lazarus bug tracker (#34947) and I'm reporting it here too, since this problem possibly indicates a bug in one of these packages. As already mentioned in the bug report Lazarus successfully compiles BGRA Bitmap and then fails during the compilation of BGRA Controls:

Free Pascal Compiler version 3.3.1-r41063 [2019/01/25] for i386
Copyright (c) 1993-2018 by Florian Klaempfl and others
(1002) Target OS: Win32 for i386
(3104) Compiling bgracontrols.pas
(3104) Compiling bcbutton.pas
(3104) Compiling bcthememanager.pas
(3104) Compiling bctypes.pas
(3104) Compiling bcbasectrls.pas
(3104) Compiling bctools.pas
(3104) Compiling bcbuttonfocus.pas
(3104) Compiling bceffect.pas
(3104) Compiling bcfilters.pas
(3104) Compiling bcgamegrid.pas
(3104) Compiling bcimagebutton.pas
(10001) PPU Loading C:\Laz\config_lazarus\onlinepackagemanager\packages\bgrabitmap-master\bgrabitmap\lib\i386-win32\3.3.1\bgraslicescaling.ppu
(10011) PPU Source: bgraslicescaling.pas not found
(10028) Recompiling BGRASliceScaling, checksum changed for C:\Laz\config_lazarus\onlinepackagemanager\packages\bgrabitmap-master\bgrabitmap\lib\i386-win32\3.3.1\bgrabitmap.ppu
C:\Laz\config_lazarus\onlinepackagemanager\packages\bgracontrols-master\bcimagebutton.pas(55,32) Fatal: (10022) Can't find unit BGRASliceScaling used by BCImageButton
Fatal: (1018) Compilation aborted
Error: C:\Laz\fpc\bin\i386-win32\ppc386.exe returned an error exitcode


This problem looks similar to the one descriped here: http://forum.lazarus.freepascal.org/index.php/topic,43665.msg308559.html#msg308559

What I'm asking myself is, if there is an easy way to avoid this sort of problem that does not seem to occur only infrequently? What about e.g. a "multi-package-installation mode", i.e. a flag that tells FPC to use .ppu files without checking for corresponding .pas files, if a .ppu file's date is not older than the timestamp that has been provided with the flag; then if there are mulitple packages selected for installation, Lazarus could take the timestamp when the Install button is clicked and set the flag for the compilation of every package. Shouldn't this avoid such issues or are there other preferred solutions?

Michael

lainz

  • Hero Member
  • *****
  • Posts: 3179
    • Lainz
Re: Error installing BGRA Bitmap and BGRA Controls packages
« Reply #1 on: January 27, 2019, 11:18:33 pm »
Usually recompiling the IDE in mode clean up + build all solves the problem, for this and for many other problems.

mmmmm

  • Newbie
  • Posts: 2
Re: Error installing BGRA Bitmap and BGRA Controls packages
« Reply #2 on: January 28, 2019, 11:36:15 pm »
Thank you very much for that hint. Unfortunately it didn't lead to success in this case. There seems to be something wrong with the configuration of the BGRA Controls package.

lainz

  • Hero Member
  • *****
  • Posts: 3179
    • Lainz
Re: Error installing BGRA Bitmap and BGRA Controls packages
« Reply #3 on: January 28, 2019, 11:54:08 pm »
I'm not sure, there is not much configuration for packages, the only setting I changed is turned on optimizations, maybe set the same value that is using BGRABitmap to see it that helps.

att2

  • New member
  • *
  • Posts: 45
Re: Error installing BGRA Bitmap and BGRA Controls packages
« Reply #4 on: January 29, 2019, 10:17:31 pm »
I have to recompile IDE with "optimized IDE", then recompile the IDE again with "Debug IDE" - __then__ it works (Linux-User speaking here).
I hate it too. This is ridiculous. Some packages/modules are only properly installed/compiled when you first select "optimized IDE" and then "Debug IDE". Ridiculous!!!

Cyrax

  • Hero Member
  • *****
  • Posts: 740
Re: Error installing BGRA Bitmap and BGRA Controls packages
« Reply #5 on: January 30, 2019, 12:41:04 am »
I have to recompile IDE with "optimized IDE", then recompile the IDE again with "Debug IDE" - __then__ it works (Linux-User speaking here).
I hate it too. This is ridiculous. Some packages/modules are only properly installed/compiled when you first select "optimized IDE" and then "Debug IDE". Ridiculous!!!


Sounds like that there is some bug on how FPC does optimizations passes. You can disable optimizations by passing -O- option to FPC compiler.