Forum > Linux

Installing Lazarus 1.8.4 on Ubuntu 18.04

(1/20) > >>

Today I upgraded my Ubuntu Mate 17.10 to 18.04 and then Lazarus 1.8.2 to 1.8.4. At the beginning my several attempts to install Lazarus 1.8.4 were failed. Luckily, I managed to install Lazarus 1.8.4 at the end. Here I want to share how I did it, maybe it can be useful for others.

If you don't understand how to use Gdebi, Synaptic Package Manager then you should not try what I did. Also remember: always do proper backup especially for the config files.

You can read my previous tutorial Installing Lazarus 1.8.0 on Ubuntu 17.10 if you want to know more about Gdebi, Synaptic Package Manager, Version Locking. Read here:,39281.0.html

My previous system before software upgrade:
Ubuntu Mate 17.10 Intel 64-bit
Lazarus 1.8.2 64-bit

I use the deb files downloaded from:

I use these tools:
- Gdebi (makes installing deb packages easier)
- Synaptic Package Manager (for inspecting problem and do version locking)

After I upgraded to Ubuntu Mate 18.04 64-bit, I continued to Install Lazarus 1.8.4:

Attempts That Failed

01. Uninstalled Lazarus, fpc-src, fpc
02. Installed fpc_3.0.4-3_amd64.deb using Gdebi
03. Installed fpc-src_3.0.4-2_amd64.deb using Gdebi
04. Failed to install lazarus-project_1.8.4-0_amd64.deb using Gdebi

On step #04, I got a "Dependency is not satisfiable" error and the installation cannot continue. See image1.

Installation That Succeed

01. Uninstalled Lazarus, fpc-src, fpc
02. Installed fpc_3.0.4-3_amd64.deb using Gdebi
03. Installed fpc-src_3.0.4-2_amd64.deb using Gdebi
04. Restarted the computer
05. Disconnect the internet connection
06. Installed lazarus-project_1.8.4-0_amd64.deb using Gdebi
07. Got "multiple lazarus" warning, see image2
08. For issue on #07, click "Start system default" and do step #09
09. Removed /home/handoko/.lazarus/bin folder
10. Got "incorrect configuration" warning, see image3
11. For issue on #10, click "Update info"
12. Did version locking on fpc using Synaptic Package Manager

Usually you don't need step #04 but in some rare cases, you really need it.

I had to do step #12, because using Synaptic Package Manager I learned that fpc is waiting to be update. I have several bad experiences, Ubuntu told me to update my fpc and I did as what it said, after that my Lazarus failed to start.

I'm not sure, but it seems the step #05 was the thing caused my installation succeed.


Although Lazarus 1.8.4 was installed after I finished the 12 steps above, it showed "error while linking" error if I tried rebuilding the IDE. You can read my posts below to learn how I solved it.

But in short, I've done 2 things: I reinstalled OpenGL-related libraries (using Synaptic Package Manager) and removed OpenGL-related packages in the IDE (in my case: LazOpenGL Context, BGRABitmap, Castle Game Engine).


The know if the FPC is in the update list or not using Synaptic Package Manager, read here:,41326.msg288471.html#msg288471

:'( Unfortunately, the installation wasn't fully success. I got "error while linking" error when trying to rebuild my Lazarus. I can't use Lazarus 1.8.4 because I need to install third party components. For now I just reinstall back my Lazarus 1.8.2 and wait new release of Lazarus.

Someone has the same issue as mine too:,41482.msg287880.html#msg287880


Try step 3 from here:
It's about BGRA_Installation, but most likely will fix the linking error.

Thank you GetMem. After I done that, I still get the same error.

One thing is sure one or more library is still missing(or wrong version). Set the filtering setting to the lowest "Filter none" in the Message Window. Do you get any extra information on rebuild? Can you please copy the messages to clipboard and paste it here?


[0] Message Index

[#] Next page

Go to full version