Forum > OpenGL

[Solved] Install OpenGL on QT IDE macOS

(1/2) > >>

lainz:
Hi, is possible to install OpenGL package on QT based IDE on macOS?

I've installed the IDE with Fpcupdeluxe.

Phil:

--- Quote from: lainz on June 05, 2018, 04:28:22 pm ---Hi, is possible to install OpenGL package on QT based IDE on macOS?

--- End quote ---

I don't see why not. Try it and see.

I would use trunk since the opengl package files are much more recent there.

Note that the package supports Qt4 only, not Qt5.

Note that Apple is deprecating OpenGL and OpenCL with the next version of macOS.

lainz:

--- Quote from: Phil on June 05, 2018, 04:34:56 pm ---
--- Quote from: lainz on June 05, 2018, 04:28:22 pm ---Hi, is possible to install OpenGL package on QT based IDE on macOS?

--- End quote ---

I don't see why not. Try it and see.

I would use trunk since the opengl package files are much more recent there.

Note that the package supports Qt4 only, not Qt5.

Note that Apple is deprecating OpenGL and OpenCL with the next version of macOS.

--- End quote ---

Hi, yes I've tested with no result, for that I asked here. I forgot to mention that.

And yes, I'm using trunk.

I'm not sure the version of Qt I have, I've used fpcupdeluxe.

Ah, ok, if it's beign deprecated, then has no sense of installing it =)

Phil:

--- Quote from: lainz on June 05, 2018, 05:40:42 pm ---I'm not sure the version of Qt I have, I've used fpcupdeluxe.

Ah, ok, if it's beign deprecated, then has no sense of installing it =)

--- End quote ---

Look in /Library/Frameworks to see what version of the Qt libraries you have.

Although deprecated, you can still use OpenGL. Just a nudge towards using Metal instead, which has much better performance.

lainz:
Yes, thanks I will look at it, the version of Qt and Metal.

Navigation

[0] Message Index

[#] Next page

Go to full version