Recent

Author Topic: [Solved] Install OpenGL on QT IDE macOS  (Read 3384 times)

lainz

  • Hero Member
  • *****
  • Posts: 3228
    • Lainz
[Solved] Install OpenGL on QT IDE macOS
« on: June 05, 2018, 04:28:22 pm »
Hi, is possible to install OpenGL package on QT based IDE on macOS?

I've installed the IDE with Fpcupdeluxe.
« Last Edit: June 05, 2018, 05:40:53 pm by lainz »

Phil

  • Hero Member
  • *****
  • Posts: 2750
Re: Install OpenGL on QT IDE macOS
« Reply #1 on: June 05, 2018, 04:34:56 pm »
Hi, is possible to install OpenGL package on QT based IDE on macOS?

I don't see why not. Try it and see.

I would use trunk since the opengl package files are much more recent there.

Note that the package supports Qt4 only, not Qt5.

Note that Apple is deprecating OpenGL and OpenCL with the next version of macOS.

lainz

  • Hero Member
  • *****
  • Posts: 3228
    • Lainz
Re: Install OpenGL on QT IDE macOS
« Reply #2 on: June 05, 2018, 05:40:42 pm »
Hi, is possible to install OpenGL package on QT based IDE on macOS?

I don't see why not. Try it and see.

I would use trunk since the opengl package files are much more recent there.

Note that the package supports Qt4 only, not Qt5.

Note that Apple is deprecating OpenGL and OpenCL with the next version of macOS.

Hi, yes I've tested with no result, for that I asked here. I forgot to mention that.

And yes, I'm using trunk.

I'm not sure the version of Qt I have, I've used fpcupdeluxe.

Ah, ok, if it's beign deprecated, then has no sense of installing it =)

Phil

  • Hero Member
  • *****
  • Posts: 2750
Re: Install OpenGL on QT IDE macOS
« Reply #3 on: June 05, 2018, 05:44:27 pm »
I'm not sure the version of Qt I have, I've used fpcupdeluxe.

Ah, ok, if it's beign deprecated, then has no sense of installing it =)

Look in /Library/Frameworks to see what version of the Qt libraries you have.

Although deprecated, you can still use OpenGL. Just a nudge towards using Metal instead, which has much better performance.

lainz

  • Hero Member
  • *****
  • Posts: 3228
    • Lainz
Re: [Solved] Install OpenGL on QT IDE macOS
« Reply #4 on: June 05, 2018, 05:45:36 pm »
Yes, thanks I will look at it, the version of Qt and Metal.

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7459
Re: [Solved] Install OpenGL on QT IDE macOS
« Reply #5 on: June 05, 2018, 05:46:10 pm »
Seems Metal2 is the successor. Do all still supported versions of OS X support metal 2?

Phil

  • Hero Member
  • *****
  • Posts: 2750
Re: [Solved] Install OpenGL on QT IDE macOS
« Reply #6 on: June 05, 2018, 06:10:26 pm »
Seems Metal2 is the successor. Do all still supported versions of OS X support metal 2?

Metal was introduced in 10.11 (El Capitan). I believe Metal2 is only 10.13 and later (High Sierra and Mojave).

https://developer.apple.com/metal


Phil

  • Hero Member
  • *****
  • Posts: 2750
Re: [Solved] Install OpenGL on QT IDE macOS
« Reply #7 on: June 05, 2018, 08:34:27 pm »
Yes, thanks I will look at it, the version of Qt and Metal.

More information here about OpenGL deprecation:

https://appleinsider.com/articles/18/06/05/some-game-developers-hint-at-abandoning-the-mac-if-apple-phases-out-opengl

Sometimes deprecated stuff hangs around for a long time. Doesn't look like OpenGL has been updated on Mac for many years.

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7459
Re: [Solved] Install OpenGL on QT IDE macOS
« Reply #8 on: June 05, 2018, 09:10:19 pm »
For the people needing a crossplatform solution, seems a MoltenVK is a Vulkan to Metal conversion layer.