Recent

Author Topic: [SOLVED] Generic error while rebuilding Lazarus IDE on Linux Mint  (Read 3902 times)

JD

  • Hero Member
  • *****
  • Posts: 1793
Hi there everyone,

I just tried to rebuild my Lazarus IDE on Linux Mint and I cannot do it because the compiler gives me the following error

Code: [Select]
Build IDE: Exit code 512, Errors: 1
lazarus.pp(161,1) Error: Error while linking

Any ideas how I can fix this problem?

Thanks for your assistance,

JD
« Last Edit: January 25, 2018, 02:49:48 pm by JD »
Windows (10, 7) - Lazarus 2.1/FPC 3.2, Delphi

Indy 10.6 series; mORMot; Zeos 7.3; SQLite, Firebird, PostgreSQL & MariaDB; VirtualTreeView 5.5.3 R1

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8716
  • FPC developer.
Re: Generic error while rebuilding Lazarus IDE on Linux Mint
« Reply #1 on: January 25, 2018, 12:48:40 pm »
Install whatever library is missing, that should be visible in the lines above those lines, usually something like

ld: library not found for -lxxx

JD

  • Hero Member
  • *****
  • Posts: 1793
Re: Generic error while rebuilding Lazarus IDE on Linux Mint
« Reply #2 on: January 25, 2018, 12:52:10 pm »
Install whatever library is missing, that should be visible in the lines above those lines, usually something like

ld: library not found for -lxxx

Sorry but that is all I have from the compiler. See screenshot

Windows (10, 7) - Lazarus 2.1/FPC 3.2, Delphi

Indy 10.6 series; mORMot; Zeos 7.3; SQLite, Firebird, PostgreSQL & MariaDB; VirtualTreeView 5.5.3 R1

GetMem

  • Hero Member
  • *****
  • Posts: 3757
Re: Generic error while rebuilding Lazarus IDE on Linux Mint
« Reply #3 on: January 25, 2018, 01:01:12 pm »
See point 3 from here: http://wiki.lazarus.freepascal.org/BGRA_Installation_on_Linux . You may not need all those libraries, but usually installing them fix the linking error.

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8716
  • FPC developer.
Re: Generic error while rebuilding Lazarus IDE on Linux Mint
« Reply #4 on: January 25, 2018, 01:15:45 pm »
Right click on the messages and configure your filters, retry

JD

  • Hero Member
  • *****
  • Posts: 1793
Re: Generic error while rebuilding Lazarus IDE on Linux Mint
« Reply #5 on: January 25, 2018, 02:49:25 pm »
Right click on the messages and configure your filters, retry

Great trick marcov! I did it and it gave me a message saying /usr/bin/ld: cannot find -lGL

I then went to the link suggested by GetMem, searched for the GL text on the page, found it and installed just the following via the terminal
sudo apt-get install libgl1-mesa-dev and it solved the problem.  :D

I explained the steps in case any other person has the same problem.

Many thanks, marcov & GetMem,

JD
« Last Edit: January 25, 2018, 02:51:03 pm by JD »
Windows (10, 7) - Lazarus 2.1/FPC 3.2, Delphi

Indy 10.6 series; mORMot; Zeos 7.3; SQLite, Firebird, PostgreSQL & MariaDB; VirtualTreeView 5.5.3 R1

 

TinyPortal © 2005-2018