Recent

Author Topic: Error while linking  (Read 2922 times)

ncastrog

  • Newbie
  • Posts: 1
Error while linking
« on: December 21, 2017, 06:27:12 pm »
Hello all.

I am new to Lazarus, and installed 1.8.0 along with fp 3.0.4 from rpm x86_64, both where installed by yum.

I tried a simple form with just a button and a textfield.

While compiling I get:
Compilar proyecto, Objetivo: project1: Código de salida 256, Errores: 1, Sugerencias: 1
unit1.pas(19,28) Hint: Parameter "Sender" not used
[3.207] Executing "/usr/bin/ld" with command line "-b elf64-x86-64 -m elf_x86_64  --dynamic-linker=/lib64/ld-linux-x86-64.so.2    -L. -o project1 link.res"
project1.lpr(20,1) Error: Error while linking
project1.lpr(20,1) Verbose: There were 1 errors compiling module, stopping

I searched and found similar problems but with older versions. Those do not solve the problem :(
https://forum.lazarus.freepascal.org/index.php?topic=37995.0

Thanks in advance.

Thaddy

  • Hero Member
  • *****
  • Posts: 9399
Re: Error while linking
« Reply #1 on: December 21, 2017, 06:38:50 pm »
can you type this in a terminal window:
ld --version

It should be 2.28 or higher:
Code: Bash  [Select]
  1. ~/fpc311 $ ld --version
  2. GNU ld (GNU Binutils for Raspbian) 2.28

also related to equus asinus.

jomaraki

  • Newbie
  • Posts: 1
Re: Error while linking
« Reply #2 on: May 02, 2018, 06:49:28 am »
I tried both rpm install and tar.gz install.  Got the same error on linking, I am on CentOS 7 full install.   I found all the dependencies I could find and still couldn't get the small test program to run without getting a linking error and exit code of 256.   I'd like detailed instructions on how to install this beast of a program and fpc because apparently the bits and pieces supplied online are not doing it for me.

I learned Turbo Pascal on an Commodore 128 in the 80's and had no problems installing the program back then as I recall.  So this is just plain weird.  I've been doing linux since 1994, SCO Unix before that!   So I am not new its just CentOS 7 that isn't cooperating I guess.  LOL

Thaddy

  • Hero Member
  • *****
  • Posts: 9399
Re: Error while linking
« Reply #3 on: May 02, 2018, 11:42:11 am »
Old hands is not an excuse. They (me included) are convinced they are right. So I just tested a CentOs 7 VM and can't by the life of me not reproduce your problem.....
also related to equus asinus.