Recent

Author Topic: Could not load Glut from libglut.so.3  (Read 4105 times)

jcaser1948

  • Jr. Member
  • **
  • Posts: 51
Could not load Glut from libglut.so.3
« on: December 20, 2017, 05:19:10 pm »
 I try to compile the OpenGl Tutorial programm as descriebed in http://wiki.lazarus.freepascal.org OpenGL_Tutorial#Multitexturing_.28extensions.29.
It does compile, but after launching th programm in the Linux terminal  I get :
An unhandled exception occurred at $000000000044999E:
Exception: Could not load Glut from libglut.so.3
  $000000000044999E
  $000000000044AB64
By compiling I recieve unknow exception  "Not supported in GDB<5.3". But this concerns only the debbuger

My sistem Opensuse Linux leap 42.3 I have followed all the steps descriebed in the tutorial  Has anyone an Idea ?
Thanks
« Last Edit: December 20, 2017, 06:59:52 pm by jcaser1948 »

Handoko

  • Hero Member
  • *****
  • Posts: 3163
  • My goal: build my own game engine using Lazarus
Re: Could not load Glut from libglut.so.3
« Reply #1 on: December 20, 2017, 05:27:54 pm »
I am not an OpenGL expert, but I remember I can use multitexturing by simply putting GLext in the uses clause.

jcaser1948

  • Jr. Member
  • **
  • Posts: 51
Re: Could not load Glut from libglut.so.3
« Reply #2 on: December 20, 2017, 06:21:44 pm »
Dear Handoko
Thanks for your suggestion I have tried with Glex.It does compile, but I still get the same error

molly

  • Hero Member
  • *****
  • Posts: 2345
Re: Could not load Glut from libglut.so.3
« Reply #3 on: December 20, 2017, 07:14:38 pm »
Have you installed libglut ?

jcaser1948

  • Jr. Member
  • **
  • Posts: 51
Re: Could not load Glut from libglut.so.3
« Reply #4 on: December 21, 2017, 08:05:51 am »
 :https://forum.lazarus.freepascal.org/Smileys/ExcellentSmileys1/smile.gif)
Thanks Molly. This was the problem. I did not install Libglut. Now it works. But in the tutorial is not mentioned that Libglut has to be istalled, so one is lead to believe that, if someone proceeds by the book, the Programm will compile, but this is not the case.Perhaps someone could make this notice in it
Thanks to anyone involved

Handoko

  • Hero Member
  • *****
  • Posts: 3163
  • My goal: build my own game engine using Lazarus
Re: Could not load Glut from libglut.so.3
« Reply #5 on: December 21, 2017, 01:15:29 pm »
I found from my tests on Ubuntu Mate 17.10, to be able to use OpenGL Utility Toolkit (GLUT) I have to install libgles2-mesa-dev package.

molly

  • Hero Member
  • *****
  • Posts: 2345
Re: Could not load Glut from libglut.so.3
« Reply #6 on: December 21, 2017, 05:39:08 pm »
You're welcome jcaser1948  :)

Note that it _is_ written in that same wiki, e.g. here:
Quote
Note: GLUT is deprecated.

GLUT (pronounced like the glut in gluttony) is the OpenGL Utility Toolkit, a window system independent toolkit for writing OpenGL programs. It implements a simple windowing application programming interface (API) for OpenGL. GLUT makes it considerably easier to learn about and explore OpenGL programming. GLUT provides a portable API so you can write a single OpenGL program that works across all PC and workstation OS platforms.

You can find more information about GLUT here.

Many Operating Systems come with preinstalled GLUT, but if yours does not have one you can easily find it using Google.

Windows binaries can be downloaded from www.xmission.com.

The GLUT FPC units information is here OpenGL.
Note how the wiki conveniently redirects you to google  ;D

And there we've come to the note of user Handoko. Every distribution seems to solve this in its own manner. Sometimes glut is pre-installed, other times you require to install another (sometimes seems unrelated) packages, other times it is enough to simply install libglut (as you did).

When you try to load a library dynamically, the loadlibrary functionality is able to report back to you so that you can check if a library was correctly loaded or not. Another much seen error is mixing 64 and 32 bit.
« Last Edit: December 21, 2017, 05:40:48 pm by molly »