Recent

Author Topic: Package AnchorDockingDsgn does not compile  (Read 7121 times)

Munair

  • Sr. Member
  • ****
  • Posts: 473
  • Try to KISS (keep it simple, smart)
    • Ditrianum
Re: Package AnchorDockingDsgn does not compile
« Reply #15 on: November 02, 2017, 03:45:15 pm »
OK, FPC 3.0.0 seems to work with Lazarus 1.8.

After building I set the widgetset to qt5 in build options. This gave a compile error at the last line 'end.' saying Lazarus could not be built.

Changing qt5 to qt solved the problem, so I take it qt5 support isn't 100% yet.

BTW installing the package anchordockingdsgn ran flawlessly with version 1.8.
Lazarus 2.0.4; Manjaro, Debian, Windows

JuhaManninen

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3645
  • I like bugs.
Re: Package AnchorDockingDsgn does not compile
« Reply #16 on: November 02, 2017, 03:48:35 pm »
Changing qt5 to qt solved the problem, so I take it qt5 support isn't 100% yet.
Correct.

Quote
BTW installing the package anchordockingdsgn ran flawlessly with version 1.8.
:)   I told you! Congratulations!

Munair

  • Sr. Member
  • ****
  • Posts: 473
  • Try to KISS (keep it simple, smart)
    • Ditrianum
Re: Package AnchorDockingDsgn does not compile
« Reply #17 on: November 02, 2017, 03:56:09 pm »
Maybe the user does not have enough access rights for the directory.
For most Linux users it works though.

If that were the case then SUDO fpc .. should have allowed to compile, but it gave the same error. So it remains a mystery, but I will play around with 1.8 from the home directory.  ;)
Lazarus 2.0.4; Manjaro, Debian, Windows

alex256

  • New Member
  • *
  • Posts: 24
Re: Package AnchorDockingDsgn does not compile
« Reply #18 on: November 30, 2017, 05:40:41 pm »
I just upgraded to 1.8.0RC5 and met the same problem. I use Debian GNU/Linux and installed Lazarus package from its repos. I couldn't even rebuild the IDE with the errors simillar with the described in the topic. Then I downloaded Lazarus DEB from SourceForge, installed it and such errors disappeared.

So, it seems that this bug is present only in Lazarus from Debian/Ubuntu repos. Anyway it's very weird.

JuhaManninen

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3645
  • I like bugs.
Re: Package AnchorDockingDsgn does not compile
« Reply #19 on: November 30, 2017, 06:09:42 pm »
I just upgraded to 1.8.0RC5 and met the same problem. I use Debian GNU/Linux and installed Lazarus package from its repos.
That cannot be right. Debian repos don't have Lazarus 1.8.0RC5.

BTW, Lazarus 1.8 will be released soon now that FPC 3.0.4 is out. Unfortunately it will not be in Debian repos either anytime soon. Only rolling distros typically provide new versions quickly.

alex256

  • New Member
  • *
  • Posts: 24
Re: Package AnchorDockingDsgn does not compile
« Reply #20 on: November 30, 2017, 06:14:13 pm »
I just upgraded to 1.8.0RC5 and met the same problem. I use Debian GNU/Linux and installed Lazarus package from its repos.
That cannot be right. Debian repos don't have Lazarus 1.8.0RC5.

BTW, Lazarus 1.8 will be released soon now that FPC 3.0.4 is out. Unfortunately it will not be in Debian repos either anytime soon. Only rolling distros typically provide new versions quickly.

It is avaliable in the backports :)

https://packages.debian.org/stretch-backports/lazarus-ide-1.8