Forum > Linux PDAs

QEMU Raspbian with FPC/Lazarus


While waiting for Pi3 (20-42 days) from aliexpress, I try QEMU emulation.
I install QEMU,latest kernel kernel-qemu-4.4.34-jessie and latest image
Install everything (you have a lot tutorials on-line).
Raspbian  boot and work OK.
Try to crosscompile cmd application (first try with TForm), compile build is OK, but executable fail to run Access valiation on address xxxx.
I use Windows 10, fpcupdeluxe NewPascal and Trunk/Trunk build and crosscompile arm/linux from fpcupdeluxe. I try all ARM CPU processors.
I also try to run binary fpcupdeluxe-arm-linux, same problem same error only address is changed.
I need emulation for testing corsscompile app and need only display and networking. I don't need to install fpc/lazarus on emulation.
I resize image +4G and change swap file to 1GB (emulation have only 256MB RAM).

Any one have success with QEMU emulation and FPC/Lazarus?
Any hint?

Raspbian uses ARM Hard Float everywhere, so pass -dFPC_ARMHF when building the compiler toolchain, along with -CpARMV6 (any other optimization options is up to you).

Problem solved
Manual download and extract in cross
and add LibraryPath when complie.
Just tested mORMot sample 31 WebSockets, cross compiled client and server works fine i QEMU emulation.
TestSQL3 failed on start - investigating.


[0] Message Index

Go to full version