Recent

Author Topic: Simple programming requirement. Am I in the right place?  (Read 6254 times)

Handoko

  • Hero Member
  • *****
  • Posts: 3775
  • My goal: build my own game engine using Lazarus
Re: Simple programming requirement. Am I in the right place?
« Reply #15 on: September 30, 2017, 09:27:15 pm »
You should install them using this order:

01. fpc_3.0.2-170225_amd64.deb
02. fpc-src_3.0.2-170225_amd64.deb
03. lazarus-project_1.6.4-0_amd64.deb

Did you install all 3 of them using the order?

Also, I saw you install it using superuser account, you should not do so. You may need to uninstall them, restart your computer and reinstall again using normal user account.
« Last Edit: September 30, 2017, 09:30:56 pm by Handoko »

munair

  • Hero Member
  • *****
  • Posts: 697
  • keep it simple
    • SharpBASIC
Re: Simple programming requirement. Am I in the right place?
« Reply #16 on: September 30, 2017, 10:38:28 pm »
Actually, it is not a good idea to install individual deb files downloaded from the internet, unless you are more experienced with Linux. This is because often it conflicts with versions alreasy in the repository. This is why you get the errors.

Using Synaptic you can install Lazarus without any problems. Dependencies are resolved automatically. I never ran into directory problems as you mentioned.

However, I haven't used Ubuntu or Mint in a while. Recently I installed the latest version of Debian (9.1) and got Lazarus with FPC completely from the repo. No problems whatsoever. Debian actually never gave me problems with Lazarus, as long as you stick to the official Debian repo's.

But you have to be careful with what desktop you use. If it is GTK based, such as GNOME or XFCE then you need to install the appropriate library for Lazarus, although I believe it is the default (lcl-gtk2-1.6). If you run a Qt based desktop, like KDE, you need to install lcl-qt4-1.6). You can always install both. Your versions in Synaptic may vary depending on your Linux distro.

Anyway, with Debian 9.1 and KDE 5.8 I can develop and compile software without problems. Debian 8 didn't give me any problems either. I used Ubuntu and Mint in the past, but found they were not the ideal environment for software development because of stability issues. Debian is much more stable in this respect.

For clarity, Debian does not give you the latest software, but it does give you a very stable system. I use Lazarus 1.6.2 with FPC 3.0.0.

e_james

  • New member
  • *
  • Posts: 7
Re: Simple programming requirement. Am I in the right place?
« Reply #17 on: October 02, 2017, 06:47:02 am »
Success!!

I had another go at installing from the Mint 18 repository and got the error message about "packager/globallinks" is missing. So I tried the same thing on one of my Lubuntu 14.04 PCs and the installation worked perfectly. With some research I established that missing globallinks is a significant problem. Next I rebooted the laptop (which I was trying not to do), into Lubuntu 16.04 and the repository installation again worked perfectly. After several more reboots I found the problem - it seems that Lubuntu Synaptic installs lcl as a dependency but Mint 18 Synaptic does not. Once I installed lcl the error messages went away and everything seems to work.

For the benefit of anyone reading this at a future time here's my suggestion for installing from the repository using Synaptic.

First install everything starting "fpc" except the Kylix component
Second install everything starting "lazarus" and make sure everything starting "lcl" is also installed.
   Choose your desktop - GTK or Qt or both

As a test, after starting Lazarus, select "Tools" - "Build Lazarus with Profile: Normal IDE" and watch the messages window. If you get any error messages at this point, I don't have any more answers.

Thanks to all for the suggestions and recommendations. I expect I will need programming advice from time to time once I get properly started.

 

TinyPortal © 2005-2018