Recent

Author Topic: TDrawGrid - can't set size  (Read 5261 times)

Andre

  • Guest
TDrawGrid - can't set size
« on: July 11, 2004, 12:01:03 am »
Hi,
I'm trying to use the TDrawgrid-Component, but it doesn't work like I suspect it should do... Basically I can't resize the component with the handles on the edge of it. I also can't set the size with the width and height attributes - after changing them, they switch back to their previous values.
The overall behaviour when trying to resize it with the mouse is pretty "jumpy", it doesn't resizes as smooth as the other components but rather jumps around, resizing only one dimension at a time.

Actually this prevents me from using this component at the moment, because I can't make it so big that all cells are fitting in it without the need for srcoll bars. If anyone could tell me how to set this in the right way (or that there's a bug in it ;) I'd be happy...

I'm using Lazarus 0.9.1 beta on Windows XP. "Snap to Grid" & "Snap to Guidelines" are off.

Thanks,
André

jesusr

  • Sr. Member
  • ****
  • Posts: 470
Re: TDrawGrid - can't set size
« Reply #1 on: July 11, 2004, 05:56:19 am »
Quote from: "Andre"
Hi,
I'm trying to use the TDrawgrid-Component, but it doesn't work like I suspect it should do... Basically I can't resize the component with the handles on the edge of it. I also can't set the size with the width and height attributes - after changing them, they switch back to their previous values.
The overall behaviour when trying to resize it with the mouse is pretty "jumpy", it doesn't resizes as smooth as the other components but rather jumps around, resizing only one dimension at a time.

Actually this prevents me from using this component at the moment, because I can't make it so big that all cells are fitting in it without the need for srcoll bars. If anyone could tell me how to set this in the right way (or that there's a bug in it ;) I'd be happy...

I'm using Lazarus 0.9.1 beta on Windows XP. "Snap to Grid" & "Snap to Guidelines" are off.

Thanks,
André


This wasn't a TDrawGrid but a win32 lcl interface problem, which in the mean time was fixed in the CVS lazarus version.  I mean, 0.9.1 beta is the current but it might not be the latest.

I'm unfamiliar with snapshot versions, so I could only recommend download the latest CVS version.

or .... on a second thought, could it be the windows version?. It works fine here under win98.

Regards.

Jesus Reyes A.