Forum > Linux

Identifier not found

(1/1)

rhlaw:
I just downloaded lazarus, fpc, and fpc-src onto Linux Redhat 9.0.  I tried to write a very simple form.  It only had a buttont that was going to quit.  When I tried to build the project.  I got the following errors:

Error: Identifier not found "TForm1"
Error: Identifier not found "Form1"

The versions that i have installed are:
fpc-1.9.3-040529.i386.rpm
fpcsrc-1.9.3-040529.i386.rpm
lazarus-0.9.1.4-fpc_1.9.3_040529.i386.rpm

I don't know Pascal very well and I'm a beginner when it comes to Delphi like programming, so I may have something setup wrong.

Any help would be greatly appeciated.

Lightning:
Install:
FPC binary
FPC source
Lazarus binary
Lazarus source
It works for me on RedHat 9
Install from console using "rpm -ivh your_package_name.rpm"
Uninstall using "rpm -e your_package_name"(without the i386 and the .rpm extension)
OR use mc (Midnight Commander) to get inside the package and use INSTALL or UPGRADE options.
mc will tell you if your package/archive is BAD

Vincent Snijders:
See http://lazarus-ccr.sourceforge.net/index.php?wiki=LazarusTutorial
for a lazarus tutorial.

My guess is you used the wrong application type and the unit with your form was not included in the main program.
does your main program have
uses unit1?

Navigation

[0] Message Index

Go to full version