Forum > Windows CE

Windows CE compact embedded 7 - HELP!!!!

<< < (3/3)

Any Luck??

You might want to check out and see if that works

You could miss a dll....
Compare of Windows  sys directory

Hi there, so here is a little description how to remove the dependencies of agyshell for WinCE systems:

in WinCEInt.pp remove the use of agyshell in the uses clauses

--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---{$ifdef Win32}    win32compat,  {$else}    //aygshell,  {$endif}
Do the same in WinCEProc.pp and WinCEWSmenus.pp.

When you now compile you should get some errors. This is cause some record types and constants are declared in Agyshell.pp that are needed.

Copy the required declarations from aygshell to the unit files.
After that, still some compile errors while occure. this are the SH* functions of the aygshell. Comment them out. Most of the call seems to be useless anyway.
After this the compiliation should work without errors and the compiled program work without aygshell.dll.

Btw, using the LCL Forms worked with one form, creating a second form resulted in a continous poping up of the second form. I'm not sure if this a problem in the LCL framework or in the missing aygshell.
Using standard WIN-API everything is working well, also the creation of a second or third windows.


--- Quote from: neopos on June 14, 2017, 11:06:45 am ---Tying to run a simple app on a Motorola MC3200 PDT with Windows CE7 using and ARM OMAP4 (Cortex A9) processor.
Getting EAccessViolation $00012708.

Previously running the same app on a Motorola MC3100 with Windows CE 6. No Problem.

--- End quote ---

I had same problem. Older device procesor and older WinCE has supported only ARMv5 architecture and supplied Win32->WinCE cross-compiler and packages were compiled for older CPU type.

I have solved it using FpcUpDeluxe utility, which helped me to build cross compiler and recompile units/packages.
In FpcUpDeluxe I have seted "Cross Build Options Override" (in Setup+) to "-Cparmv7A" (The Cortex-A9 cores implement the ARMv7-A architecture).
After that I was able sucessfully compile and run my application on WinCE 7.


[0] Message Index

[*] Previous page

Go to full version