Recent

Author Topic: LazReport + Mysql 5.6 error  (Read 2555 times)

almusx

  • Newbie
  • Posts: 2
LazReport + Mysql 5.6 error
« on: March 01, 2017, 03:58:10 pm »
Hello everyone! I need some help, this is my first time using Lazarus after years using Delphi.

I want to make a report using Mysql as DB server. Im using SqlDB component to retrieve the data from my db and all is working perfect, i can see my dbgrid with all the data correct.

The problem is in Lazreport, i've configured a dbDataset to get the data from my sqlQuery to pass to lazReport, in my report, i can see all the fields from my dataset but when i try to preview my report i get an error: "undefined symbol".


GAN

  • Full Member
  • ***
  • Posts: 215
Re: LazReport + Mysql 5.6 error
« Reply #1 on: March 04, 2017, 04:47:35 am »
Hi, May you post some code?
Do you drop into yuor data module a tfrReport and a tfrDBDataset?

Code: Pascal  [Select]
  1. frDBDataset.DataSet:=SQLQuery1
  2. frReport1.Dataset:=frDBDataset1
  3.  

Lazarus 1.6 FPC 3.0.0 Linux Mint Mate 17.2 x86_64 GTK-2
Zeos 7.1.3 - Sqlite 3.8.2

Foro Lazarus en español http://forum.lazarus.freepascal.org/index.php/board,73.0.html

almusx

  • Newbie
  • Posts: 2
Re: LazReport + Mysql 5.6 error
« Reply #2 on: March 09, 2017, 08:58:07 pm »
I fixed my problem by moving my report to the same form of my datasets and queries. I dont know why its not working when the queries and datasets are in another form because in delphi i put all my queries in one datamodule and my reports in another. Thanks anyway.