Recent

Author Topic: [SOLVED] LAMW : how to use opendialog  (Read 4442 times)

majid.ebru

  • Sr. Member
  • ****
  • Posts: 388
[SOLVED] LAMW : how to use opendialog
« on: January 27, 2017, 07:32:29 pm »
Hi
how to use opendialog in LAMW android?
« Last Edit: February 10, 2017, 03:15:59 pm by majid.ebru »

jmpessoa

  • Hero Member
  • *****
  • Posts: 1623
Re: how to use opendialog in LAMW
« Reply #1 on: January 27, 2017, 07:52:31 pm »

Hello majid.ebru!

Please, explain better what you need and I will try find a solution ....

Thank you!
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

majid.ebru

  • Sr. Member
  • ****
  • Posts: 388
Re: how to use opendialog in LAMW
« Reply #2 on: January 27, 2017, 08:20:48 pm »
thank-you
for example i want to open text file from SD-Card and show it in memo(jEdittext)

jmpessoa

  • Hero Member
  • *****
  • Posts: 1623
Re: how to use opendialog in LAMW
« Reply #3 on: January 29, 2017, 05:34:00 am »
Please, use the new [LAMW] "jOpenDialog" component

[See the demo "AppOpenFileDialogDemo1" ...]

ref.

https://github.com/jmpessoa/lazandroidmodulewizard

Thank you!
« Last Edit: January 29, 2017, 05:39:22 am by jmpessoa »
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

majid.ebru

  • Sr. Member
  • ****
  • Posts: 388
Re: how to use opendialog in LAMW
« Reply #4 on: January 31, 2017, 05:19:38 am »
i try to open "AppOpenFileDialogDemo1"  but error?
what is my problem??
« Last Edit: January 31, 2017, 07:27:09 am by majid.ebru »

jmpessoa

  • Hero Member
  • *****
  • Posts: 1623
Re: how to use opendialog in LAMW
« Reply #5 on: January 31, 2017, 03:59:50 pm »
After updated from github you need re-instal LAMW's packages!
[so you will find the new jOpenDialog componet in the tab "Android Bridges Extra"]
« Last Edit: January 31, 2017, 07:57:54 pm by jmpessoa »
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

majid.ebru

  • Sr. Member
  • ****
  • Posts: 388
Re: how to use opendialog in LAMW
« Reply #6 on: February 06, 2017, 09:22:24 am »
hi
i download new package but when i want to compile  "lazandroidwizardpack" => error occur ?
what is my problem ?
« Last Edit: February 06, 2017, 09:28:33 am by majid.ebru »

A.S.

  • Jr. Member
  • **
  • Posts: 76
Re: how to use opendialog in LAMW
« Reply #7 on: February 06, 2017, 03:27:45 pm »
It is because the current project is LAMW project. Use empty project (menu Project->New project->Application) when compiling packages or simply rebuild IDE (menu Tools->Configure "Build Lazarus"...->Build).

majid.ebru

  • Sr. Member
  • ****
  • Posts: 388
Re: how to use opendialog in LAMW
« Reply #8 on: February 06, 2017, 04:03:15 pm »
thank you
it works

 

TinyPortal © 2005-2018