Recent

Author Topic: Compilation error on Raspberry Pi  (Read 2307 times)

stchebel

  • Newbie
  • Posts: 1
Compilation error on Raspberry Pi
« on: January 04, 2017, 08:25:25 am »
Hi,
I'm new in BGRABitmap. I have downloaded BGRABitmap v9.2.2 and it works fine on my laptop with Windows-Vista. Unfortunately when compiling on RPi, I receive a lot of compilation errors. Here are few of them:

bgradefaultbitmap.pas(254,17) Error: There is no method in an ancestor class to be overridden: "constructor TBGRADefaultBitmap.Create(AnsiString);"
bgradefaultbitmap.pas(259,17) Error: There is no method in an ancestor class to be overridden: "constructor TBGRADefaultBitmap.Create(AnsiString,Boolean);"
bgradefaultbitmap.pas(260,17) Error: There is no method in an ancestor class to be overridden: "constructor TBGRADefaultBitmap.Create(AnsiString,Boolean,TBGRALoadingOptions);"
bgradefaultbitmap.pas(282,14) Error: There is no method in an ancestor class to be overridden: "TBGRADefaultBitmap.NewBitmap(AnsiString):TBGRACustomBitmap;"

Could anybody advice me how to solve a problem?

Thanks..

Leledumbo

  • Hero Member
  • *****
  • Posts: 8273
  • Programming + Glam Metal + Tae Kwon Do = Me
Re: Compilation error on Raspberry Pi
« Reply #1 on: January 04, 2017, 08:41:22 am »
Use the same compiler version. If you get one from Raspbian repository, that's awfully outdated.

avra

  • Hero Member
  • *****
  • Posts: 2010
    • Additional info
Re: Compilation error on Raspberry Pi
« Reply #2 on: January 04, 2017, 09:09:13 am »
To get newer version that Leledumbo has mentioned, you can use fpcup or fpcupdeluxe on RPi:
https://github.com/newpascal/fpcupdeluxe/releases
ct2laz - Conversion between Lazarus and CodeTyphon
bithelpers - Bit manipulation for standard types
pasettimino - Siemens S7 PLC lib

 

TinyPortal © 2005-2018