Recent

Author Topic: Strange error - Class "TMainMenu" not found  (Read 2095 times)

Xatrix

  • New member
  • *
  • Posts: 5
Strange error - Class "TMainMenu" not found
« on: November 26, 2016, 07:12:02 pm »
Hi.

I saw strange error when try to compile my application ( about 15 units ).
Screen in attachment.

Any ideas ?

Thanks

Bart

  • Hero Member
  • *****
  • Posts: 3940
    • Bart en Mariska's Webstek
Re: Strange error - Class "TMainMenu" not found
« Reply #1 on: November 26, 2016, 07:33:35 pm »
Sorry, crystal ball is broken.

I.o.w. without code (project source, inclusing lpi) it is impossible to tell.

Bart

Xatrix

  • New member
  • *
  • Posts: 5
Re: Strange error - Class "TMainMenu" not found
« Reply #2 on: November 26, 2016, 07:40:48 pm »
Do I have to rewrite the whole application ? :(

howardpc

  • Hero Member
  • *****
  • Posts: 3549
Re: Strange error - Class "TMainMenu" not found
« Reply #3 on: November 26, 2016, 07:45:44 pm »
You could check one of two things:
Does your project's .lpr file have Interfaces in its uses clause?
Do the form(s) which have a TMainMenu include Menus in their uses clause?

If you're OK there, then either post the faulty project as Bart suggests, or rewrite it.

Xatrix

  • New member
  • *
  • Posts: 5
Re: Strange error - Class "TMainMenu" not found
« Reply #4 on: November 26, 2016, 07:52:39 pm »
You could check one of two things:
Does your project's .lpr file have Interfaces in its uses clause?
Do the form(s) which have a TMainMenu include Menus in their uses clause?

If you're OK there, then either post the faulty project as Bart suggests, or rewrite it.

Question 1 :  Interfaces, // this includes the LCL widgetset
Question 2 : only in MAIN unit
« Last Edit: November 26, 2016, 07:54:37 pm by Xatrix »

 

TinyPortal © 2005-2018