Recent

Author Topic: Can't find unit LResources  (Read 13813 times)

Arnulf

  • Newbie
  • Posts: 1
Can't find unit LResources
« on: March 08, 2007, 12:28:31 pm »
Hello
I have managed to install lazarus on ubuntu edgy and windows.
it works to compile programs with the allready installed components.
But i wanted to port delphi sources to lazarus and need internet components.

i tryed to install indy 10
and this sockets components:
http://infoconsult.homelinux.net/

but on both windows and linux i have messages like this:

C:\Programme\lazarus\components\sockets\SocketClient.pas(30,11) Fatal: Can't find unit LResources

well the LResources is in lcl folder and i tryed to set copiler directory to this.
i also tryed to rebuild lazarus - like it is described int faq  but there was no use .....

any sugestions - would love to program with delphi like ide on all platforms  but i realy have troubles to do anything :(

thx
Arnulf

knoby

  • Newbie
  • Posts: 2
Can't find unit LResources
« Reply #1 on: March 22, 2007, 02:13:13 pm »
hi

i had the same problem!!!

so i played a little bit with the settings:

in the compileroption menue put in the field for other unit files (first):

Quote
$(LazarusDir)/lcl/units/$(TargetCPU)-$(TargetOS)/


in the second, the one for the Include Files:

Quote
$(LazarusDir)/lcl/include/$(TargetCPU)-$(TargetOS)/


now you can press ok and install it :)



but now I habe a problem: when i install it it sais something like this:

Illigal qualifiere at this code ...

Quote
            tmp:=intToStr(tmp1[1])+'.'+intToStr(tmp1s[2])+'.'+intToStr(tmp1[3])+'.'+intToStr(tmp1[4]);


so i replaced it with this:

Quote
            tmp:=intToStr(tmp1.s_bytes[1])+'.'+intToStr(tmp1.s_bytes[2])+'.'+intToStr(tmp1.s_bytes[3])+'.'+intToStr(tmp1.s_bytes[4]);


now it runs very well but when lazarus restarts it crashs the console sais:

Quote

[WARNING] *******************************************************
[WARNING] **                                                   **
[WARNING] ** Multibyte character encodings (like UTF8) are not **
[WARNING] ** supported at the moment.                          **
[WARNING] ** For full keyboard event support, make sure that   **
[WARNING] ** the LANG environment var has no UTF8              **
[WARNING] **                                                   **
[WARNING] *******************************************************
Threading has been used before cthreads was initialized.
Make cthreads one of the first units in your uses clause.
Runtime error 211 at $085608F9
  $085608F9
  $08062349
  $080540BD  main,  line 79 of lazarus.pp
  $08053FFD




so does anybody know wher my mistake is ???



PS: sorry for my very bad english


Edit1: i run SUSE 10.0

Edit2: i tryed it with my windows xp HOME system and with the modifikation it worked!!!

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2661
    • My Lazarus wiki user page
Can't find unit LResources
« Reply #2 on: March 22, 2007, 09:14:06 pm »
I don't know what package you are using, but seems to have two 'bugs'.

* It depends on the LCL, so it should add LCL as one of its requirements
* It uses threading, so it should add -dUseCThreads to its usage options.

knoby

  • Newbie
  • Posts: 2
Can't find unit LResources
« Reply #3 on: April 04, 2007, 10:42:57 pm »
THX

i try it in the next days

Cigydd

  • New Member
  • *
  • Posts: 15
  • Programming for fun
    • My GitHub
Helped for another package
« Reply #4 on: October 10, 2007, 04:57:43 am »
Thank you, adding LCL to the requirements list has helped me by another package that had thrown the same error message. The package in concern is psql_laz.
Cigydd Bach