Recent

Author Topic: Build RTL & Päckages to crosscompile to FreeBSD Errors  (Read 1795 times)

BSaidus

  • Sr. Member
  • ****
  • Posts: 337
  • lazarus 1.8.4 Win8.1 / cross FreeBSD
Build RTL & Päckages to crosscompile to FreeBSD Errors
« on: November 24, 2016, 12:52:50 pm »
Hello!
SVN trunc work perfectelly, but
when I want to use a stable version of lazarus/fpc ("lazarus-1.6.2/FPC 3.0.0") to cross compile, it generate errors..
So I wonder if some one fixed the the makefile for cross compile.

Thanks.
lazarus 1.8.4 Win8.1 / cross FreeBSD
dhukmucmur vernadh!

Graeme

  • Hero Member
  • *****
  • Posts: 1430
    • Graeme on the web
Re: Build RTL & Päckages to crosscompile to FreeBSD Errors
« Reply #1 on: November 25, 2016, 11:47:42 am »
For anybody to help you, you will have to post the exact error messages you get.
--
fpGUI Toolkit - a cross-platform GUI toolkit using Free Pascal
http://fpgui.sourceforge.net/

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8795
  • FPC developer.
Re: Build RTL & Päckages to crosscompile to FreeBSD Errors
« Reply #2 on: November 25, 2016, 11:55:33 am »
If it is unit "uuchar" related, that is fixed in fixes and trunk

BSaidus

  • Sr. Member
  • ****
  • Posts: 337
  • lazarus 1.8.4 Win8.1 / cross FreeBSD
Re: Build RTL & Päckages to crosscompile to FreeBSD Errors
« Reply #3 on: November 26, 2016, 10:05:38 am »
If it is unit "uuchar" related, that is fixed in fixes and trunk
Thanks, it works for fixes branch
thank you  :)
lazarus 1.8.4 Win8.1 / cross FreeBSD
dhukmucmur vernadh!

 

TinyPortal © 2005-2018