Recent

Author Topic: [SOLVED] TMySQL56Connection and latest Linux MySQL client library 5.7  (Read 3483 times)

vrull

  • Full Member
  • ***
  • Posts: 112
Current stable Lazarus 1.6 provides TMySQL56Connection component. This worked just fine in one of my applications until I upgraded OS to Linux Mint 18, which is shipped with MySQL library version 5.7. The problem is that Lazarus component explicitly requires library version 5.6 (or 5.5 or 5.1 or 5.0), which are no longer available in the repositories.

Does anyone know how to trick TMySQL56Connection component to accept libraries ver. 5.6 AND ABOVE? I don't think all these TMySQLxxConnections are totally incompatible with each other.

Thank you.
« Last Edit: November 09, 2016, 05:50:27 am by vrull »

Thaddy

  • Hero Member
  • *****
  • Posts: 9425
Re: TMySQL56Connection and latest Linux MySQL client library 5.7
« Reply #1 on: November 08, 2016, 07:30:38 am »
57 is in FPC trunk. I don't expect issues if you use it with 3.0.0
path is ./packages/fcl-db/src/sqldb/mysql
« Last Edit: November 08, 2016, 07:37:44 am by Thaddy »
also related to equus asinus.

LacaK

  • Hero Member
  • *****
  • Posts: 577
Re: TMySQL56Connection and latest Linux MySQL client library 5.7
« Reply #2 on: November 08, 2016, 08:06:28 pm »
There is also new property "SkipLibraryVersionCheck". When you set to True, then MySQLConnection will no more check if database client library version exactly match MySQLConnection version.

vrull

  • Full Member
  • ***
  • Posts: 112
Re: TMySQL56Connection and latest Linux MySQL client library 5.7
« Reply #3 on: November 09, 2016, 05:49:51 am »
Thank you, Thaddy,
That was very simple since I create connections dynamically at runtime depending on configuration settings. Just added "mysql57conn" to uses  list and that it. The module is already there. Get connected to my MySQL server again.

@LacaK - I could not find the property "SkipLibraryVersionCheck" in mysqlconn.inc on my installation, but it is in the github. I just left it commented out for the time being.

Thank you again, the issue is resolved.