Recent

Author Topic: Fpcupdeluxe  (Read 788669 times)

geraldholdsworth

  • Full Member
  • ***
  • Posts: 195
Re: Fpcupdeluxe
« Reply #2430 on: January 28, 2024, 11:10:09 am »
Cheers guys - I'll give those a try.

tk

  • Sr. Member
  • ****
  • Posts: 361
Re: Fpcupdeluxe
« Reply #2431 on: February 01, 2024, 05:00:17 pm »
I have question to this file:
https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/download/windows_crossbins_all/Darwin_All_Clang_15.zip

I cross compile some dylibs from Win10 to MAC using the fpcupdeluxe setup on Win10 (x64).
The cross compiler works but ld reports:
Code: [Select]
Error: (9016) Util x86_64-apple-darwin19-strip.exe not found, switching to external linking
When I made an empty console app and named it x86_64-apple-darwin19-strip.exe and put it to x:\fpcupdeluxe\cross\bin\all-apple\bin\x86_64-apple-darwin19-strip.exe everything worked. The dylibs otherwise normally work on my MAC. However, obviously, the dylib files are big (not stripped).

Where to find this utility - x86_64-apple-darwin19-strip.exe? Where comes Darwin_All_Clang_15.zip from?
« Last Edit: February 01, 2024, 05:09:47 pm by tk »

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1720
Re: Fpcupdeluxe
« Reply #2432 on: February 02, 2024, 09:31:10 am »
Would you mind testing these new binaries ?
https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/download/windows_crossbins_all/Darwin_All_Clang_16.zip

Howto.
Remove all files from: C:\yourinstallpath\cross\bin\all-apple\
Unpack above file in: C:\yourinstallpath\cross\bin\all-apple\
Recompile.

qsps

  • Newbie
  • Posts: 1
Re: Fpcupdeluxe
« Reply #2433 on: February 07, 2024, 03:35:44 pm »
Greetings,
I can't open the file after downloading, the error " The application fpcupdeluxe-aarch64-darwin-cocoa is corrupted and can't be opened".
I would also like to clarify which fpcupdeluxe I need to install on MacOs M1pro.
Thank you in advance.


Hartmut

  • Hero Member
  • *****
  • Posts: 736
Re: Fpcupdeluxe
« Reply #2435 on: February 12, 2024, 11:20:25 am »
I got a "Fpcupdeluxe fatal error" when trying to install Lazarus trunk + FPC trunc today with fpcupdeluxe 2.4.0c

From my point of knowledge I cannot see if this is a fpcupdeluxe problem or if trunk is broken currently.

@DonAlfredo: can you answer this question please? Thanks in advance.

I attached a screenshot and saved both the contents of the black and the white window.


Hartmut

  • Hero Member
  • *****
  • Posts: 736
Re: Fpcupdeluxe
« Reply #2437 on: February 12, 2024, 11:53:33 am »
Thanks a lot DonAlfredo for your quick reply.

tk

  • Sr. Member
  • ****
  • Posts: 361
Re: Fpcupdeluxe
« Reply #2438 on: February 13, 2024, 10:09:18 am »

YiannisKam

  • Jr. Member
  • **
  • Posts: 89
Re: Fpcupdeluxe
« Reply #2439 on: February 17, 2024, 08:52:37 pm »
Hello, there is a problem again with fpcupdeluxe-x86_64-win64.exe(latest release), concerning trunk installation for both Lazarus and fpc.
« Last Edit: February 17, 2024, 09:01:17 pm by YiannisKam »

Thaddy

  • Hero Member
  • *****
  • Posts: 14014
  • Probably until I exterminate Putin.
Re: Fpcupdeluxe
« Reply #2440 on: February 17, 2024, 09:38:27 pm »
Known issue. This is a regression and it is being worked on with some urgency.
It involves bugs in both Lazarus and FPC, which makes it something not as ordinary as you would expect. This issue is quite complex.
At the moment it is not possible to compile Laz trunk with FPC trunk.
Be patient and do not complain: to find such issues is why we have public trunk/main versions.
(Although I am not really a fan of that, I am also  guilty of using trunks all the time, but I know what it means)
The stable versions are OK of course, so use stable.
Don't file a bug report. The issue is known and bug reports are already filed, including by me and Martin.

If you want cutting edge, this is what sometimes happens.... Take note of that before you use trunk versions. They are everything but stable.

It has nothing to do with FpcUpDeLuxe. Just with Lazarus IDE and FPC.

You can follow the progress on the bug trackers (both Laz and FPC in this case)
« Last Edit: February 17, 2024, 10:06:23 pm by Thaddy »
Specialize a type, not a var.

YiannisKam

  • Jr. Member
  • **
  • Posts: 89
Re: Fpcupdeluxe
« Reply #2441 on: February 17, 2024, 10:00:28 pm »
Thanks for the information Thaddy.

Thaddy

  • Hero Member
  • *****
  • Posts: 14014
  • Probably until I exterminate Putin.
Re: Fpcupdeluxe
« Reply #2442 on: February 17, 2024, 10:03:09 pm »
Thanks for the information Thaddy.
It is what it is and two people -or more - are breaking their brains over it this weekend.
That should be appreciated.
Specialize a type, not a var.

YiannisKam

  • Jr. Member
  • **
  • Posts: 89
Re: Fpcupdeluxe
« Reply #2443 on: February 17, 2024, 10:10:07 pm »
I agree :)

BSaidus

  • Hero Member
  • *****
  • Posts: 532
  • lazarus 1.8.4 Win8.1 / cross FreeBSD
Re: Fpcupdeluxe
« Reply #2444 on: February 29, 2024, 11:25:43 am »
Hello, @DonAlfredo.
I've tried to build lazarus 3.2 with fpc-trunk, the build was failed, tchart package do not build correctelly.
Any thing to do ?
I know that fpc-trunk shall not build successfully lazarus release.

lazarus 1.8.4 Win8.1 / cross FreeBSD
dhukmucmur vernadh!

 

TinyPortal © 2005-2018